Bug 520595 - secure EE page of OCSP throws errors - instead of a generic message to use 11443 port for agent tasks
Summary: secure EE page of OCSP throws errors - instead of a generic message to use 11...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Dogtag Certificate System
Classification: Retired
Component: OCSP Responder
Version: unspecified
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Harmsen
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 10:48 UTC by Kashyap Chamarthy
Modified: 2015-01-04 23:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-22 21:01:03 UTC


Attachments (Terms of Use)

Description Kashyap Chamarthy 2009-09-01 10:48:58 UTC
Description:

when tried to access secure EE page of OCSP, the below error message is thrown.

--------------------------------------------
Problem Processing Your Request
 

The ocsp encountered an unexpected error while processing your request. The following is a detailed message of the error that occurred.

    Error encountered while rendering a response.

Please consult your local administrator for further assistance. The Certificate System logs may provide further information. 
-------------------------------------------

Expected result: A appropriate error message must be thrown in the browser.


Note: the OCSP debug log says says 11443 should be used for agent tasks:

----------------------------------------------------------------
[01/Sep/2009:20:31:30][http-11444-Processor24]: OCSPServlet: java.lang.Exception: OCSPServlet: OCSP request not provided in GET method
[01/Sep/2009:20:31:30][http-11444-Processor24]: CMSServlet: curDate=Tue Sep 01 20:31:30 IST 2009 id=ocspOCSP time=110
[01/Sep/2009:20:31:30][http-11444-Processor24]: com.netscape.cms.servlet.filter.AgentRequestFilter:  Use HTTPS port '11443' instead of '11444' when performing Agent tasks!
--------------------------------------------------------------------

Comment 1 Chandrasekar Kannan 2009-09-01 17:38:36 UTC
can u paste the full url here ... ?

either way I don't think we have any displayable html there. It is sort of known. But I agree that a better error message will help. It a low priority bug anyways.

Comment 2 Kashyap Chamarthy 2009-09-02 08:55:09 UTC
I get the url when I run service pki-ocsp status

in this case:
https://cahostname:11444/ocsp/ee/ocsp


Note You need to log in before you can comment on or make changes to this bug.