Bug 520598 - AVC denials aren't showing up in the troubleshoot browser screen.
Summary: AVC denials aren't showing up in the troubleshoot browser screen.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 11:40 UTC by Chris Ward
Modified: 2009-09-01 14:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-01 12:50:13 UTC


Attachments (Terms of Use)
empty alert broswer (346.32 KB, image/png)
2009-09-01 11:40 UTC, Chris Ward
no flags Details
All alerts view... (374.62 KB, image/png)
2009-09-01 11:58 UTC, Chris Ward
no flags Details

Description Chris Ward 2009-09-01 11:40:34 UTC
Created attachment 359375 [details]
empty alert broswer

Description of problem:

Alerts aren't showing up in the browser screen.

Version-Release number of selected component (if applicable):
setroubleshoot-server-2.2.23-1.fc12.x86_64

How reproducible:
always, just wait for an alert in F12 alpha, shouldn't take long ;)


Actual results:
alert about a new alert pops up. Open browser screen and notice the screen is showing no alerts and no alert text.

See attachment

Expected results:
Alert should be visible.

Additional info:

I'm not selinux expert, so please tell me what I can do to help debug this issue and I'll be glad too.

Comment 1 Chris Ward 2009-09-01 11:58:13 UTC
Created attachment 359376 [details]
All alerts view...

As you can see, there are alerts to be shown, but the broswer view (first attachment) shows ~ of ~.

Comment 2 Chris Ward 2009-09-01 12:22:25 UTC
Note; If I open the All Alerts window and select one alert individually to open, then the browser works correctly.

The issue appears to occur only when opening initially.

Comment 3 Daniel Walsh 2009-09-01 12:50:13 UTC
Fixed in setroubleshoot-2.2.24-1.fc12

Comment 4 Chris Ward 2009-09-01 14:26:29 UTC
Thanks, looking forward to the update.


Note You need to log in before you can comment on or make changes to this bug.