Bug 520662 - Not possible to run a single test from sectool-gui
Summary: Not possible to run a single test from sectool-gui
Keywords:
Status: CLOSED DUPLICATE of bug 520638
Alias: None
Product: Fedora
Classification: Fedora
Component: sectool
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Maros Barabas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 16:54 UTC by Eduard Benes
Modified: 2009-09-02 06:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 06:32:56 UTC


Attachments (Terms of Use)

Description Eduard Benes 2009-09-01 16:54:08 UTC
Description of problem:
Even root user is not able to run a sigle test using the sectool-gui in F12/rawhide due to following issue with dbus:

<snip>
# sectool-gui
/usr/share/sectool/guiRender.py:1017: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips = gtk.Tooltips()
/usr/share/sectool/guiRender.py:1018: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips.enable( )
/usr/share/sectool/guiRender.py:1179: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips.set_tip(self.group_filter, _("Choose a group to filter tests"), "Private")
/usr/share/sectool/guiRender.py:1180: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltips.set_tip(self.level_filter, _("Choose a level to run the test"), "Private")

** (sectool-gui:1998): WARNING **: expected enumeration type PangoWrapMode, but got GtkWrapMode instead

** (sectool-gui:1998): WARNING **: expected enumeration type PangoWrapMode, but got GtkWrapMode instead
Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
    self.run()
  File "/usr/bin/sectool-gui", line 888, in run
    else: raise e
DBusException: org.freedesktop.PolicyKit1.Error.Failed: Action org.fedoraproject.sectool.runtests is not registered
</snip>

Version-Release number of selected component (if applicable):
# rpm -q sectool-gui
sectool-gui-0.9.4-2.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. run sectool-gui from CLI
2. right-click on any test, firewall for example
3. select "Start the selected test option" 
4. Move to tab "Test Results"
  
Actual results:
The gui says that the test is running, while it will run forever. 
You can observe Exception in Thread-2 listed above.

Expected results:
The test should run cleanly, no exception, ...

Additional info:
This works in F11 using the same packages. Seems to be related to bug #520638.
Also it would be nice to get rid of the "DeprecationWarning"s.

Comment 1 Maros Barabas 2009-09-02 06:32:56 UTC

*** This bug has been marked as a duplicate of bug 520638 ***


Note You need to log in before you can comment on or make changes to this bug.