Bug 520755 - luci fails to add system with SSL error: SSL_ERROR_ZERO_RETURN
Summary: luci fails to add system with SSL error: SSL_ERROR_ZERO_RETURN
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga
Version: 5.3
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 07:51 UTC by Ulrich Leodolter
Modified: 2012-03-02 08:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-15 19:10:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ulrich Leodolter 2009-09-02 07:51:29 UTC
Description of problem:

add systems or create new cluster using luci webinterface
fails with SSL error: SSL_ERROR_ZERO_RETURN.


this error occurs even on the local machine where luci and ricci are running.



Version-Release number of selected component (if applicable):

i tried luci/ricci from rhel 5.3 and rhel 5.4 beta

luci-0.12.2-6.el5
ricci-0.12.2-6.el5

How reproducible:


Steps to Reproduce:
1. yum install luci
2. yum install ricci
3. luci_admin init
4. service ricci start
5. service luci start
6. open luci webinterface and try to add system or create new cluster
7. enter hostname of luci/ricci machine
8. click on "View SSL cert fingerprints"

Actual results:

The following errors occurred:

    * Unable to add the key for node node1.local to the trusted keys list.
    * Unable to establish a secure connection to the ricci agent on node1.local: Unable to establish an SSL connection to node1.local:11111: unable to open temp file


Expected results:

SSL cert fingerprints

Additional info:

i tried this on RHEL 5.3 i386 without any problems.
looks like it is x86_64 specific.

Hardware info:

Sun Fire X4170 Server
Dual Quad Xeon E5540

Comment 1 Ulrich Leodolter 2009-09-02 08:15:10 UTC
Looks like other people have this problem too:

https://www.centos.org/modules/newbb/viewtopic.php?topic_id=20633

Comment 2 Ulrich Leodolter 2009-09-03 08:32:43 UTC
found the problem, IT IS NOT A BUG


it was a /tmp/ permission problem.

Comment 3 vicman 2011-04-06 20:43:22 UTC
Need help with the next problem...
I try to add the nodos cluster on luci and get the next...
The following errors occurred:

    * Unable to add the key for node pga2 to the trusted keys list.
    * Unable to connect to pga2: Unable to establish an SSL connection to pga2:11111: ClientSocket(hostname, port, timeout): connect() failed
 
How can fix that!?
I found the next...
> it was a /tmp/ permission problem.

But I don't really understand what that means... I chance the permissions on /tmp
but dont fix the problem :S

I should to chance the permission of /tmp on principal node or the other nodes.

Someone explain me! please!

Well Thanks!

Comment 4 Armando 2012-03-01 22:49:05 UTC
(In reply to comment #2)
> found the problem, IT IS NOT A BUG
> it was a /tmp/ permission problem.

Can you give a little more detail on how did you fix this ?  We will appreciate



Thanks!!

Comment 5 Ulrich Leodolter 2012-03-02 08:41:42 UTC
Hi,

/tmp was mounted on extra filesystem and had default permission 0755

if fixed the problem using chmod:

chmod 1777 /tmp/


Best regards
Ulrich


Note You need to log in before you can comment on or make changes to this bug.