Bug 520778 - unhandled exception when attempting to create more than 4 primary partition
Summary: unhandled exception when attempting to create more than 4 primary partition
Keywords:
Status: CLOSED DUPLICATE of bug 519784
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: ia32e
OS: All
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 10:38 UTC by IBM Bug Proxy
Modified: 2009-09-02 14:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 14:13:11 UTC


Attachments (Terms of Use)
report saved through gui (211.41 KB, text/plain)
2009-09-02 10:38 UTC, IBM Bug Proxy
no flags Details
tar.gz files from /tmp/ directory (56.41 KB, application/octet-stream)
2009-09-02 10:38 UTC, IBM Bug Proxy
no flags Details


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 55874 None None None Never

Description IBM Bug Proxy 2009-09-02 10:38:06 UTC
=Comment: #0=================================================
Chandru S <> - 
During F12 Alpha installation , it wasn't intentional, but I was unknowingly creating more than 4
primary partitions on the disk. This caused an exception and the only option from here was to save
the report, debug it or exit. I saved the report and the installer exited too.  System needs a
reboot to start the installation again. 

Kernel version 2.6.31-0.125.4.2.rc5.git2.fc12  , F12 Alpha

=Comment: #3=================================================
Edward E. Pollard <edpollar@linux.ibm.com> - 
anaconda 12.15 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 202, in addPartition
    constraint.getPedConstraint())
  File "/usr/lib/python2.6/site-packages/parted/decorators.py", line 30, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in addPartition
  File "/usr/lib/anaconda/storage/partitioning.py", line 832, in allocatePartitions
    constraint=constraint)
  File "/usr/lib/anaconda/storage/partitioning.py", line 591, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1019, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1127, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 976, in newCB
    self.editPartition(device, isNew=1)
PartitionException: Too many primary partitions.

=================================================
files attached:-
report saved through gui
tar.gz files from /tmp/ directory

Comment 1 IBM Bug Proxy 2009-09-02 10:38:19 UTC
Created attachment 359501 [details]
report saved through gui

Comment 2 IBM Bug Proxy 2009-09-02 10:38:29 UTC
Created attachment 359503 [details]
tar.gz files from /tmp/ directory

Comment 3 Chris Lumens 2009-09-02 14:13:11 UTC

*** This bug has been marked as a duplicate of bug 519784 ***


Note You need to log in before you can comment on or make changes to this bug.