Bug 520848 - fence_ipmilan reboot command fails with idrac6
Summary: fence_ipmilan reboot command fails with idrac6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 16:12 UTC by PaulB
Modified: 2016-04-26 13:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 14:55:24 UTC


Attachments (Terms of Use)

Description PaulB 2009-09-02 16:12:45 UTC
Description of problem:
I have a dell system w an enterprise version idrac6 	
w the latest firmware 1.13.01 

the -P option is required for ipmilan

running sbin/fence_ipmilan -P -o on
is successful

running /sbin/fence_ipmilan -P -o off
is successful

However, running /sbin/fence_ipmilan -P -o reboot
FAILS every other attempt
======================================================================================================================
Here is the result of a FAILED attempt:

 /sbin/fence_ipmilan -P -o reboot -a SystemDracFQDN -l root -p calvin -v
Rebooting machine @ IPMI:SystemDracFQDN...Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power off'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power on'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
ipmilan: Power still off
Failed
======================================================================================================================

Here is the result of a successful attempt:

 /sbin/fence_ipmilan -P -o reboot -a SystemDracFQDN -l root -p calvin -v
Rebooting machine @ IPMI:SystemDracFQDN...Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power on'...
Spawning: '/usr/bin/ipmitool -I lanplus -H SystemDracFQDN -U root -P calvin -v chassis power status'...
Done
======================================================================================================================

Version-Release number of selected component (if applicable):
I am running cman 2.0.98-1.el5_3.7

How reproducible:
everytime

Steps to Reproduce:
1./sbin/fence_ipmilan -P -o reboot -a SystemDracFQDN -l root -p calvin -v


Expected results:

This command should work every time.

Comment 1 Jan Friesse 2009-09-24 09:13:39 UTC
Paul,
it looks like you are using 5.3z version. There were many changes between 5.3 and 5.4 version and I'm pretty sure, that one of patches fix this bug too.

Can you please try to reproduce problem on real 5.4 (cman 2.0.115) or you really want patch for Z-stream?

Comment 2 PaulB 2009-09-29 14:39:26 UTC
Hello Jan,
I was running cman0.1.9.2-8.el5 and tried cman2.0.113-1.el5 prior to opening this bz. This issue was still existing using cman2.0.113-1.el5.

However, upgrading to the recently available cman2.0.115-1.el5, as suggested, has resolved the issue.

This issue is resolved.

Thanks, Jan.
-PaulB

Comment 3 Jan Friesse 2009-09-29 14:55:24 UTC
Reporter says, that current release is working, so I'm closing the bug as CURRENT RELEASE.


Note You need to log in before you can comment on or make changes to this bug.