Bug 520895 - setroubleshoot: SELinux is preventing NetworkManager "getattr" access on <Unknown>.
Summary: setroubleshoot: SELinux is preventing NetworkManager "getattr" access on...
Keywords:
Status: CLOSED DUPLICATE of bug 520892
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:716a1178551...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 19:27 UTC by Matěj Cepl
Modified: 2018-04-11 10:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 10:12:11 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-02 19:27:34 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing NetworkManager "getattr" access on <Unknown>.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by NetworkManager. It is not expected that this
access is required by NetworkManager and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                unconfined_u:system_r:NetworkManager_t:s0
Kontext cíle                 unconfined_u:system_r:NetworkManager_t:s0
Objekty cíle                 None [ netlink_kobject_uevent_socket ]
Zdroj                         NetworkManager
Cesta zdroje                  /usr/sbin/NetworkManager
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          NetworkManager-0.7.995-3.git20090813.fc12
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.28-9.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.190.rc8.fc12.x86_64 #1 SMP
                              Fri Aug 28 18:51:58 EDT 2009 x86_64 x86_64
Počet upozornění           2
Poprvé viděno               So 29. srpen 2009, 18:34:14 CEST
Naposledy viděno             Po 31. srpen 2009, 18:41:26 CEST
Místní ID                   6e3e41c3-b4f0-453d-a570-bf6e29a52a44
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1251736886.30:225): avc:  denied  { getattr } for  pid=11702 comm="NetworkManager" scontext=unconfined_u:system_r:NetworkManager_t:s0 tcontext=unconfined_u:system_r:NetworkManager_t:s0 tclass=netlink_kobject_uevent_socket

node=(removed) type=SYSCALL msg=audit(1251736886.30:225): arch=c000003e syscall=51 success=yes exit=0 a0=a a1=7fff4d39a890 a2=7fff4d39a8a8 a3=310600d730 items=0 ppid=1 pid=11702 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=unconfined_u:system_r:NetworkManager_t:s0 key=(null)


audit2allow suggests:

#============= NetworkManager_t ==============
allow NetworkManager_t self:netlink_kobject_uevent_socket getattr;

Comment 1 Daniel Walsh 2009-09-08 10:12:11 UTC

*** This bug has been marked as a duplicate of bug 520892 ***


Note You need to log in before you can comment on or make changes to this bug.