Bug 52098 - mii-tools completely broken
mii-tools completely broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
David Lawrence
http://www.scyld.com/diag/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-20 11:05 EDT by Aleksey Nogin
Modified: 2013-07-02 22:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 11:42:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2001-08-20 11:05:08 EDT
mii-tools always shows all zeros for me. It used to work correctly in 7.1
(on the same HW).

Compare the following outputs of mii-tools from net-tools-1.60-3 and Donald
Becker's mii-diag:

[alexei@home alexei]# /sbin/mii-tool  -vv eth0
eth0: 10 Mbit, half duplex, no link
  registers for MII PHY 0:
    0000 0000 0000 0000 0000 0000 0000 0000
    0000 0000 0000 0000 0000 0000 0000 0000
    0000 0000 0000 0000 0000 0000 0000 0000
    0000 0000 0000 0000 0000 0000 0000 0000
  product info: vendor 00:00:00, model 0 rev 0
  basic mode:   10 Mbit, half duplex
  basic status: no link
  capabilities:
  advertising:

[alexei@home alexei]# /usr/local/sbin/mii-diag -vv eth0
mii-diag.c:v2.02 5/21/2001 Donald Becker (becker@scyld.com)
 http://www.scyld.com/diag/index.html
 Basic mode control register 0x2100: Auto-negotiation disabled, with
 Speed fixed at 100 mbps, full-duplex.
 Basic mode status register 0x780b ... 780f.
   Link status: previously broken, but now reestablished.
   This transceiver is capable of  100baseTx-FD 100baseTx 10baseT-FD 10baseT.
   Able to perform Auto-negotiation, negotiation not complete.
   *** Link Jabber! ***
 Link partner information is not exchanged when in fixed speed mode.
   End of basic transceiver information.
 
 MII PHY #1 transceiver registers:
   2100 780f 2000 5c00 01e1 0000 0000 0000
   0000 0000 0000 0000 0000 0000 0000 0000
   0000 0000 0000 0000 0000 0000 0000 8462
   8000 0021 0000 3800 a3b9 0044 0c05 001d.
 Basic mode control register 0x2100: Auto-negotiation disabled!
   Speed fixed at 100 mbps, full-duplex.
 Basic mode status register 0x780f ... 780f.
   Link status: established.
   Capable of  100baseTx-FD 100baseTx 10baseT-FD 10baseT.
   Able to perform Auto-negotiation, negotiation not complete.
   *** Link Jabber! ***
 Vendor ID is 08:00:17:--:--:--, model 0 rev. 0.
   No specific information is known about this transceiver type.
 I'm advertising 01e1: 100baseTx-FD 100baseTx 10baseT-FD 10baseT
   Advertising no additional info pages.
   IEEE 802.3 CSMA/CD protocol.
 Link partner capability is 0000:.
   Negotiation did not complete.
Comment 1 Bill Nottingham 2001-08-20 15:14:32 EDT
It was changed to use the proper ioctl, not SIOCDEVPRIVATE.
This means that the ioctl isn't getting through to the kernel right.
Comment 2 Arjan van de Ven 2001-08-20 15:17:33 EDT
What card is this ?
Comment 3 Aleksey Nogin 2001-08-20 15:24:10 EDT
on-board eepro100
Comment 4 Aleksey Nogin 2002-07-28 13:09:29 EDT
Seems to be OK in fully up2date'd Limbo:

# /sbin/mii-tool -vv eth0
eth0: 100 Mbit, full duplex, link ok
  registers for MII PHY 1:
    2100 780f 2000 5c00 01e1 0000 0000 0000
    0000 0000 0000 0000 0000 0000 0000 0000
    0000 0000 0000 0000 0000 0000 0000 8462
    8000 0021 0000 3800 a3b9 0046 0b05 001d
  product info: National DP83840A rev 0
  basic mode:   100 Mbit, full duplex
  basic status: link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
Comment 5 Arjan van de Ven 2002-07-28 13:21:15 EDT
mii-tools are still depricated in favor of ethtool
Comment 6 Aleksey Nogin 2002-07-30 15:46:53 EDT
> mii-tools are still depricated in favor of ethtool

Well, how do I get the same information out of ethtool? 

# /usr/sbin/ethtool -i eth0
driver: eepro100
version: eepro100.c:v1.09j-t 9/29/99 Don
firmware-version:
bus-info: 00:06.0

# /usr/sbin/ethtool eth0
Settings for eth0:
No data available
Comment 7 Jeff Garzik 2002-10-25 12:50:35 EDT
I'm closing this bug.  Comments indicate mii-tool works now.

WRT ethtool, you need an updated eepro100.c from kernel.org to add in the
necessary ethtool support.

Note You need to log in before you can comment on or make changes to this bug.