Bug 521003 - Sabayon does not pick up changes to the panel .desktop files.
Summary: Sabayon does not pick up changes to the panel .desktop files.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sabayon
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tomáš Bžatek
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 05:37 UTC by Wade Mealing
Modified: 2018-11-14 19:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-17 00:40:52 UTC


Attachments (Terms of Use)
Proposed patch (4.41 KB, patch)
2009-10-19 08:45 UTC, Olivier Fourdan
no flags Details | Diff

Description Wade Mealing 2009-09-03 05:37:31 UTC
Description of problem:

Changes made through sabayon to the panel launchers does not get saved.


Version-Release number of selected component (if applicable):

2.12.4.6

How reproducible:

Pretty much every time.

Steps to Reproduce:
1. Create a new sabayon profile
2. Edit the profile, add a new application launcher to the top panel
3. Quit the xnest session.
4. Go back in, make a change to the panel launcher
5. Quit the xnest ession
  
Actual results:

Last change not propgated to the application launcher.


Expected results:

The change to stick.


Additional info:

The modified desktop file does not make its way to the new /etc/desktop-profiles/profilename.zip .  Ive attempted to chase it down but have had no luck.

Comment 2 Olivier Fourdan 2009-10-19 08:45:25 UTC
Created attachment 365215 [details]
Proposed patch

The current code upstream is known to work. Yet, the desktop file is ignored in Sabayon 2.12.4 while upstream also uses the same delegation for panel items (lib/sources/paneldelegate.py) so the delegation is unlikely the culprit.

The problem actually comes from dirmonitor, which was ported from gamin to gnome-vfs, and then later to gio.

During the process the bug was fixed. The attached patch actually backports the same logic from current dirmonitor with gio, but with gamin in 2.12.4 for el5.

The desktop file seems to be properly updated with this patch.

Comment 5 RHEL Product and Program Management 2009-11-06 18:57:39 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 7 RHEL Product and Program Management 2011-05-31 14:19:52 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.


Note You need to log in before you can comment on or make changes to this bug.