Bug 521032 - setroubleshoot: SELinux is preventing modem-manager "setopt" access on <Unknown>.
Summary: setroubleshoot: SELinux is preventing modem-manager "setopt" access on &...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:b6719086b3c...
: 521034 521035 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 09:30 UTC by Matěj Cepl
Modified: 2018-04-11 14:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 10:36:39 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-03 09:30:25 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing modem-manager "setopt" access on <Unknown>.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by modem-manager. It is not expected that this
access is required by modem-manager and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                system_u:system_r:initrc_t:s0-s0:c0.c1023
Kontext cíle                 system_u:system_r:initrc_t:s0-s0:c0.c1023
Objekty cíle                 None [ netlink_kobject_uevent_socket ]
Zdroj                         modem-manager
Cesta zdroje                  /usr/sbin/modem-manager
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          ModemManager-0.2-3.20090826.fc12
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.30-1.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.190.rc8.fc12.x86_64 #1 SMP
                              Fri Aug 28 18:51:58 EDT 2009 x86_64 x86_64
Počet upozornění           2
Poprvé viděno               Čt 3. září 2009, 10:50:05 CEST
Naposledy viděno             Čt 3. září 2009, 11:04:56 CEST
Místní ID                   1dac0eaf-d6f6-48c8-8e10-a449bd29d5f2
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1251968696.558:13): avc:  denied  { setopt } for  pid=1403 comm="modem-manager" scontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tclass=netlink_kobject_uevent_socket

node=(removed) type=SYSCALL msg=audit(1251968696.558:13): arch=c000003e syscall=54 success=yes exit=0 a0=6 a1=1 a2=1a a3=310600d730 items=0 ppid=1 pid=1403 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="modem-manager" exe="/usr/sbin/modem-manager" subj=system_u:system_r:initrc_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t self:netlink_kobject_uevent_socket setopt;

Comment 1 Daniel Walsh 2009-09-08 10:36:39 UTC
I think this might be a labeling problem

restorecon -R -v /usr/sbin/modem-manager

Should be 
Fixed in selinux-policy-3.6.30-4.fc12.noarch

Comment 2 Daniel Walsh 2009-09-08 10:37:07 UTC
*** Bug 521034 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-08 10:37:25 UTC
*** Bug 521035 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.