Bug 521061 - Virtualization for ia64 not working with satellite
Summary: Virtualization for ia64 not working with satellite
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization
Version: 530
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Devan Goodwin
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks: 462714 500798
TreeView+ depends on / blocked
 
Reported: 2009-09-03 12:09 UTC by Petr Sklenar ⛄
Modified: 2009-09-15 15:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-15 15:49:28 UTC


Attachments (Terms of Use)

Description Petr Sklenar ⛄ 2009-09-03 12:09:56 UTC
Description of problem:
virtualization host is working with virt-manager but satellite is not supporting virt-features. 

Version-Release number of selected component (if applicable):
satellite with ia64base/rhn client tools/VT channels
 Satellite-5.3.0-RHEL5-re20090820.1

# uname -a
Linux ia64-m00.englab.brq.redhat.com 2.6.18-126.el5xen #1 SMP Mon Dec 8 18:52:39 EST 2008 ia64 ia64 ia64 GNU/Linux
# rpm -qa | grep xen
xen-libs-3.0.3-79.el5
kernel-xen-2.6.18-126.el5
kernel-xen-2.6.18-120.el5
xen-ia64-guest-firmware-1.0.13-1
xen-3.0.3-79.el5

How reproducible:
always

Steps to Reproduce:
1. make virtualization working on ia64 - try xen-guest creation in virt-manager
2. register the xen-host to satellite
3. add Entitlements:  	 [Virtualization] 
4. rhn_check  + its not supporting by satellite


Actual results:
1. rhn_check -vv after added Entitlements: "[Virtualization]" : 

# rhn_check -vv
D: check_action {'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>packages.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><array><data>\n<value><string>rhn-virtualization-host</string></value>\n<value><string>5.3.0</string></value>\n<value><string>4.el5sat</string></value>\n<value><string></string></value>\n<value><string>noarch</string></value>\n</data></array></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 429}
updateLoginInfo() login info
D: login(forceUpdate=True) invoked
logging into up2date server
D: writeCachedLogin() invoked
D: Wrote pickled loginInfo at  1251981069.09  with expiration of  1251984669.09  seconds.
successfully retrieved authentication token from up2date server
D: logininfo: {'X-RHN-Server-Id': 1000010509, 'X-RHN-Auth-Server-Time': '1251973393.13', 'X-RHN-Auth': 'LNEVFjLmq05JDaUeFCiaQA==', 'X-RHN-Auth-Channels': [['rhel-ia64-server-5', '20090902161659', '1', '1'], ['rhn-tools-rhel-ia64-server-5', '20090902161514', '0', '1'], ['rhel-ia64-server-vt-5', '20090902161701', '0', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action {'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>packages.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><array><data>\n<value><string>rhn-virtualization-host</string></value>\n<value><string>5.3.0</string></value>\n<value><string>4.el5sat</string></value>\n<value><string></string></value>\n<value><string>noarch</string></value>\n</data></array></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 429}
D: handle_action actionid = 429, version = 2
D: do_call packages.update ([['rhn-virtualization-host', '5.3.0', '4.el5sat', '', 'noarch']],)
D: Called update [['rhn-virtualization-host', '5.3.0', '4.el5sat', '', 'noarch']]
Loaded plugins: rhnplugin
D: Sending back response ((6,), 'Fatal error in Python code occured', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: Called refresh_rpmlist
Updating package profile
D: local action status:  (0, 'rpmlist refreshed', {})

satellite webUI > ia64-xen-host > Virtualization 
List is empty but there is few xen-guests

 > Provisioning 
 cannot select any my ia64-xenguest-kickstarts

Expected results:
host download some pkgs + satellite supports xen-virt

Additional info:

Comment 2 Petr Sklenar ⛄ 2009-09-15 15:49:28 UTC
works for me
tried two hosts: freshly installed ia64 rhel54 from rhts
created three pv rhel54 guests - all works

originaly in Comment #1 - It was wrongly set ia64

not_a_bug


Note You need to log in before you can comment on or make changes to this bug.