Bug 521085 - gnome-desktop lock screen not working
gnome-desktop lock screen not working
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-03 10:57 EDT by Michael Hoffman
Modified: 2015-01-14 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-05 01:29:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Hoffman 2009-09-03 10:57:53 EDT
Description of problem:
When clicking "Lock Screen" or using the shortcut of "Ctl-Alt-L" the user is immediately logged out instead of locking the screen as expected

Version-Release number of selected component (if applicable):
Fedora 11.92 (Fedora 12 Alpha)

How reproducible:
Log into gnome as regular non-privileged user.  Lock the screen.

Steps to Reproduce:
1.Log into gnome desktop as non-privileged user.
2.Lock screen either through shortcut (mentioned above) or through system menu

  
Actual results:
User is logged out

Expected results:
The user's session is locked and screen saver activated or returned to login screen showing that the user is still active.

Additional info:
Comment 1 Matthias Clasen 2009-09-03 21:06:19 EDT
Works fine here. Is this reproducible ? Is gnome-screensaver running in your session ?
Comment 2 Michael Hoffman 2009-10-23 11:22:36 EDT
I do have gnome-screensaver running.  this problem still exists.  Please note that I have tried this when upgrading from fedora11 stable to fedora 12 alpha and doing a straight fedora 12 alpha install.  Not sure where any additional debugging information is captured to provide you with more details.  I have reproduced this on 3 machines now.  2 upgraded from f11 and 1 new install.  I have also tried to use the system->lock screen action item to no avail.
Comment 3 Bug Zapper 2009-11-16 06:57:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tim Taiwanese Liim 2010-05-01 00:27:06 EDT
Michael,
Do you still see this issue?  Now it (ctrl-alt-L locks screen) works
well on my several F12.
Comment 5 Tim Taiwanese Liim 2010-08-13 15:01:21 EDT
Michael,
Any news?  If not, can we close this bug?
Comment 6 Bug Zapper 2010-11-04 06:13:32 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2010-12-05 01:29:40 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.