Bug 521113 - concatenation problem in kernel parameters in grub.conf?
Summary: concatenation problem in kernel parameters in grub.conf?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 523620 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 18:02 UTC by Clyde E. Kunkel
Modified: 2009-09-16 09:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 08:46:03 UTC


Attachments (Terms of Use)
grub.conf with concatenation problem (764 bytes, text/plain)
2009-09-03 18:05 UTC, Clyde E. Kunkel
no flags Details

Description Clyde E. Kunkel 2009-09-03 18:02:30 UTC
Description of problem:
rhgb quietLANG=en_US.UTF-8SYSFONT=latarcyrheb-sun16 run together in kernel parameter line in grub.conf

Version-Release number of selected component (if applicable):
12.20

How reproducible:
every time

Steps to Reproduce:
1. fresh rawhide install from 20090903
2.
3.
  
Actual results:
rhgb quietLANG=en_US.UTF-8SYSFONT=latarcyrheb-sun16

Expected results:
rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16

Additional info:

Comment 1 Clyde E. Kunkel 2009-09-03 18:05:22 UTC
Created attachment 359711 [details]
grub.conf with concatenation problem

Hmmmm....msg from bz that attachment failed....trying again

Comment 2 Hans de Goede 2009-09-03 18:14:47 UTC
To save our heroic bug triagers some time: I'll take this one.

Comment 3 Hans de Goede 2009-09-04 08:13:59 UTC
Hmm, I cannot reproduce this, did you do anything special during the installation ?

Can you reproduce it yourself? (By doing another install)

Comment 4 Clyde E. Kunkel 2009-09-04 12:36:24 UTC
I don't believe I did anything special.  I try to use the same routine for every install...selinux=0, radeon.modeset=0 (nomodeset hasn't been working) custom layout, mounting some predetermined ext3 and 4 partitions, mounting my home LV parition, formatting / lv as ext4 and boot parition as ext3.  I did repeat the install and the same concatenation occurred on both attempts.

I will try again this AM.

Comment 5 Clyde E. Kunkel 2009-09-04 15:25:05 UTC
Two tests, all using the 20090903 boot.iso and method=http://mirrors.tds.net/pub/fedora/development/x86_64/os

1)  boot parms (in addition to default): selinux=0 radeon.modeset=0 method=http://<as above>

formatted /boot on /dev/sdf8, / on lv, mounted some other LVs and /dev/sdf partitions, took default install

result: 
title Fedora (2.6.31-0.199.rc8.git2.fc12.x86_64)
	root (hd0,7)
	kernel /vmlinuz-2.6.31-0.199.rc8.git2.fc12.x86_64 ro root=/dev/mapper/VolGroup00-Fedora12 rhgb quietLANG=en_US.UTF-8SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /initrd-generic-2.6.31-0.199.rc8.git2.fc12.x86_64.img

2)  boot parms (in addition to default): selinux=0 nomodeset method=http://<as above>

formatted /boot on /dev/sdf8, / on lv, mounted some other LVs and /dev/sdf partitions, took default install

result: 
title Fedora (2.6.31-0.199.rc8.git2.fc12.x86_64)
	root (hd0,7)
	kernel /vmlinuz-2.6.31-0.199.rc8.git2.fc12.x86_64 ro root=/dev/mapper/VolGroup00-Fedora12 nomodeset rhgb quietLANG=en_US.UTF-8SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /initrd-generic-2.6.31-0.199.rc8.git2.fc12.x86_64.img

Comment 6 Clyde E. Kunkel 2009-09-04 21:03:58 UTC
and now an attempt on a F11 VM with a plain vanilla standard partition configuration, boot.iso and boot parms same as 2) in comment 5 and the result is the same as test 2).

Comment 7 Clyde E. Kunkel 2009-09-05 16:37:16 UTC
issue still present with rawhide 20090905 and its boot.iso. Tried both VM and regular installs.

Interesting thing is, I don't see any errors at boot time except for the raid grep issue which doesn't seem to affect my raid arrays.

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,7)
#          kernel /vmlinuz-version ro root=/dev/mapper/VolGroup00-Fedora12
#          initrd /initrd-[generic-]version.img
#boot=/dev/sdf8
default=0
timeout=0
splashimage=(hd0,7)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31-0.203.rc8.git2.fc12.x86_64)
	root (hd0,7)
	kernel /vmlinuz-2.6.31-0.203.rc8.git2.fc12.x86_64 ro root=/dev/mapper/VolGroup00-Fedora12 nomodeset rhgb quietLANG=en_US.UTF-8SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /initrd-generic-2.6.31-0.203.rc8.git2.fc12.x86_64.img

Comment 8 Hans de Goede 2009-09-06 08:32:40 UTC
Ah, my bad I was reproducing this with a too old version. I've got the problem now, and a fix is on its way.

Thanks for your perseverance.

Comment 9 Hans de Goede 2009-09-08 08:46:03 UTC
This is fixed by this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=30c28b26233dd70a74ad69c7e7056643bb667b43

Which will be in anaconda-12.22-1, which will hit rawhide in a couple of days.

Comment 10 Hans de Goede 2009-09-16 09:50:02 UTC
*** Bug 523620 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.