Bug 521127 - openssl speed camellia-192-cbc segfaults
Summary: openssl speed camellia-192-cbc segfaults
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openssl
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-03 18:44 UTC by Pekka Pietikäinen
Modified: 2009-10-08 15:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-08 15:36:11 UTC


Attachments (Terms of Use)

Description Pekka Pietikäinen 2009-09-03 18:44:14 UTC
Description of problem:

The other variants seem fine, but

(gdb) set args speed camellia-192-cbc
(gdb) run
Starting program: /usr/bin/openssl speed camellia-192-cbc
[Thread debugging using libthread_db enabled]
Doing camellia-192 cbc for 3s on 16 size blocks: 
Program received signal SIGSEGV, Segmentation fault.
_x86_64_Camellia_encrypt () at cmll-x86_64.s:232
232		movl	64(%r14),%ebx
Current language:  auto
The current source language is "auto; currently asm".
(gdb) bt
#0  _x86_64_Camellia_encrypt () at cmll-x86_64.s:232
#1  0x00000036cfe814b4 in Camellia_cbc_encrypt () at cmll-x86_64.s:1686

which looks a bit worrying, considering the nature of openssl

Version-Release number of selected component (if applicable):

openssl-1.0.0-0.6.beta3.fc12.x86_64

Comment 1 Tomas Mraz 2009-09-04 11:49:10 UTC
It seems related to the compiler options used but I don't think it is caused by patches we apply in our RPM package.

I've reported the problem upstream, we'll see what happens. Meanwhile I'll disable using the assembler code for Camellia on x86_64.

Comment 2 Tomas Mraz 2009-10-08 15:36:11 UTC
Fixed in openssl-1.0.0-0.8.beta3.fc12.x86_64.


Note You need to log in before you can comment on or make changes to this bug.