Bug 521254 - Jface assertion failed in Eclipse PDE
Jface assertion failed in Eclipse PDE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
: 521272 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-04 10:39 EDT by Rod Schultz
Modified: 2009-09-08 11:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 11:47:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack Trace (6.42 KB, application/octet-stream)
2009-09-04 10:39 EDT, Rod Schultz
no flags Details

  None (edit)
Description Rod Schultz 2009-09-04 10:39:58 EDT
Created attachment 359818 [details]
Stack Trace

Description of problem:

Assertion failed in jface when opening launch configuration in debug mode of plugin development environment.


Version-Release number of selected component (if applicable):
Fedora Eclipse 3.4.2
PDE project also failes on Fedora Core 11 with local install of downloaded version of Eclipse 3.4.2.
PDE project works with downloaded version of Eclipse on RedHat 5.3.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andrew Overholt 2009-09-04 10:48:03 EDT
(In reply to comment #0)
> PDE project also failes on Fedora Core 11 with local install of downloaded
> version of Eclipse 3.4.2.

Thank you for the bug report.  The above indicates that this is a problem with the upstream code.  Therefore, this should be reported at bugs.eclipse.org.

Have you tried 3.5?
Comment 2 Rod Schultz 2009-09-04 11:50:25 EDT
I have tried 3.5 and it has the same behavior. 

The assertion fails on Fedora Core 11. It works as expected on RedHat 5.3

Since it works on RedHat, I don't understand why you think this might be an Eclipse problem rather than a Fedora one?
Comment 3 Andrew Overholt 2009-09-04 13:10:20 EDT
*** Bug 521272 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Overholt 2009-09-04 13:12:18 EDT
(In reply to comment #2)
> I have tried 3.5 and it has the same behavior. 

Okay, that's good.  A bug upstream is really the best way to go here.  If it's failing with an upstream download on Fedora 11, then the fault lies upstream and not in the Fedora package (which isn't patching anything that could affect this).

> Since it works on RedHat, I don't understand why you think this might be an
> Eclipse problem rather than a Fedora one?  

Because RHEL 5.3 is a lot older than Fedora 11.  It sounds like an underlying GNOME or Gtk library changed in between RHEL 5.3 and Fedora 11.  Either in API or in behaviour.
Comment 5 Rod Schultz 2009-09-04 13:35:34 EDT
Reported to Eclipse as bug: 288668
Comment 6 Rod Schultz 2009-09-08 11:42:22 EDT
The problem is in the client side code. A dependency was incompletely installed.

The Eclipse team was very helpful, as were you. Thanks for the quick response.
Comment 7 Andrew Overholt 2009-09-08 11:47:46 EDT
Glad to be of service.

Note You need to log in before you can comment on or make changes to this bug.