Bug 521283 - Enable debuginfo generation for llvm
Enable debuginfo generation for llvm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-04 12:22 EDT by Jerry James
Modified: 2009-09-09 10:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 01:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
llvm spec file patch to enable debuginfo generation (670 bytes, patch)
2009-09-04 12:22 EDT, Jerry James
no flags Details | Diff

  None (edit)
Description Jerry James 2009-09-04 12:22:07 EDT
Created attachment 359828 [details]
llvm spec file patch to enable debuginfo generation

Description of problem:
No debuginfo.

Version-Release number of selected component (if applicable):
llvm-2.5-2.fc11.x86_64

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
See attached patch.
Comment 1 Michel Alexandre Salim 2009-09-09 00:22:20 EDT
Aha, thanks! This is not needed for 2.6 anymore, but since 2.5 will be on F-11 for a bit longer, I'll test this and push an update asap.
Comment 2 Michel Alexandre Salim 2009-09-09 01:06:46 EDT
This does not work:

http://koji.fedoraproject.org/koji/getfile?taskID=1664048&name=build.log

I tried adding KEEP_SYMBOLS=1 to the build process and that does not work either.

This could probably wait until the final release of 2.6, after which we only have to wait until OpenGTL has a 2.6-compatible release before F-11's llvm will get updated to 2.6
Comment 3 Jerry James 2009-09-09 10:48:45 EDT
Hmmmm, that worked for a local build....  Well, if 2.6 fixes it, then let's not worry about it.  Thanks for trying.

Note You need to log in before you can comment on or make changes to this bug.