Bug 521315 - imapsync with ssl does not work
Summary: imapsync with ssl does not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: imapsync
Version: 10
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Marek Mahut
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-04 18:14 UTC by Tomasz Kepczynski
Modified: 2009-10-06 16:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-06 16:21:31 UTC


Attachments (Terms of Use)

Description Tomasz Kepczynski 2009-09-04 18:14:22 UTC
Description of problem:

geralt:~> imapsync --host1 imap.gmail.com --ssl1 --host2 imap.gmail.com --ssl2 --justconnect                    
$RCSfile: imapsync,v $ $Revision: 1.286 $ $Date: 2009/07/24 15:53:04 $
Here is a [linux] system (Linux geralt 2.6.27.30-170.2.82.fc10.x86_64 #1 SMP Mon Aug 17 08:18:34 EDT 2009 x86_64)
with perl 5.10.0
Mail::IMAPClient  3.08
IO::Socket        1.30_01
IO::Socket::SSL
Digest::MD5       2.36_01
Digest::HMAC_MD5  1.01
Term::ReadKey
Date::Manip
 and the module Mail::IMAPClient version used here is 3.08
Command line used:
/usr/bin/imapsync --host1 imap.gmail.com --ssl1 --host2 imap.gmail.com --ssl2 --justconnect
Can't locate object method "Ssl" via package "Mail::IMAPClient" at /usr/bin/imapsync line 601.


Version-Release number of selected component (if applicable):

imapsync-1.286-1.fc10.noarch
perl-Mail-IMAPClient-3.08-1.fc10.noarch
perl-5.10.0-73.fc10.x86_64


How reproducible:
Always

Comment 1 Nick Bebout 2009-10-06 16:21:31 UTC
I believe this should be fixed with the current version of perl-Mail-IMAPClient and current version of imapsync.


Note You need to log in before you can comment on or make changes to this bug.