Bug 521323 - second kvm host is not shown in "System > Virtual System"
Summary: second kvm host is not shown in "System > Virtual System"
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization
Version: 530
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714 500798
TreeView+ depends on / blocked
 
Reported: 2009-09-04 18:54 UTC by Petr Sklenar ⛄
Modified: 2014-07-04 13:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 13:28:38 UTC


Attachments (Terms of Use)
systems > overview (182.76 KB, image/jpeg)
2009-09-04 18:56 UTC, Petr Sklenar ⛄
no flags Details
systems > virtual systems (210.10 KB, image/jpeg)
2009-09-04 18:59 UTC, Petr Sklenar ⛄
no flags Details

Description Petr Sklenar ⛄ 2009-09-04 18:54:00 UTC
Description of problem:
second kvm host is not shown in "System > Virtual System" and its kvm-guests belong to first kvm-host.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090820.1

How reproducible:
I tried that only once, because lack of virtual hosts ..

Steps to Reproduce:
1. register the first kvm host called "kvm-host-dhcp-lab-159"
2. create at least one guest on kvm-host-dhcp-lab-159 and register this guest
3. register the second kvm host called "dhcp-lab-131.englab.brq.redhat.com"
4. create at least one guest on second kvm-host and register this guest.
5. webUI: System > Virtual System

  
Actual results:
-host: kvm-host-dhcp-lab-159
  |__guest created in #2
  |__guest created in #4 
      ^which is guest of the second system - dhcp-lab-131.englab.brq.redhat.com

:( there is not the second kvm-host

Expected results:
-host: kvm-host-dhcp-lab-159
  |__guest created in #2

-host: dhcp-lab-131.englab.brq.redhat.com
  |__guest created in #

Additional info:
this works:
There is right 'virtual-system-picture' for each kvm-host in main system list. When I click to first or second kvm-hosts' details then their guests are shown correctly. I rebooted both kvm-hosts machines and restarted rhn-virtualization-host many times.

Comment 1 Petr Sklenar ⛄ 2009-09-04 18:56:33 UTC
Created attachment 359836 [details]
systems > overview

systems > overview
See that both kvm-hosts are with right "virtual" icons.

Comment 2 Petr Sklenar ⛄ 2009-09-04 18:59:37 UTC
Created attachment 359838 [details]
systems > virtual systems

systems > virtual systems
see that there is only one host and all guests belongs to it which is wrong. There isn't shown second kvm-host.


Note You need to log in before you can comment on or make changes to this bug.