Bug 521373 - setroubleshoot: SELinux is preventing Xorg "bind" access on <Unknown>.
Summary: setroubleshoot: SELinux is preventing Xorg "bind" access on <Unknown&...
Keywords:
Status: CLOSED DUPLICATE of bug 521372
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:8dbcec8ece8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 10:12 UTC by Sebastiano M. Cossu
Modified: 2018-04-11 16:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 11:28:57 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-05 10:12:20 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing Xorg "bind" access on <Unknown>.

Descrizione dettagliata:

[Xorg has a permissive type (xserver_t). This access was not denied.]

SELinux denied access requested by Xorg. It is not expected that this access is
required by Xorg and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:xserver_t:s0-s0:c0.c1023
Contesto target               system_u:system_r:xserver_t:s0-s0:c0.c1023
Oggetti target                None [ netlink_kobject_uevent_socket ]
Sorgente                      Xorg
Percorso della sorgente       /usr/bin/Xorg
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        xorg-x11-server-Xorg-1.6.99-45.20090903.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.199.rc8.git2.fc12.i686 #1 SMP
                              Wed Sep 2 21:10:11 EDT 2009 i686 i686
Conteggio avvisi              3
Primo visto                   ven 04 set 2009 16:03:01 CEST
Ultimo visto                  sab 05 set 2009 12:02:17 CEST
ID locale                     0a24293b-5365-497f-b232-7029c1b21fdc
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252144937.831:18): avc:  denied  { bind } for  pid=1327 comm="Xorg" scontext=system_u:system_r:xserver_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xserver_t:s0-s0:c0.c1023 tclass=netlink_kobject_uevent_socket

node=(removed) type=SYSCALL msg=audit(1252144937.831:18): arch=40000003 syscall=102 success=yes exit=0 a0=2 a1=bf9031e0 a2=5d570fc a3=a1d0940 items=0 ppid=1326 pid=1327 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="Xorg" exe="/usr/bin/Xorg" subj=system_u:system_r:xserver_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xserver_t ==============
allow xserver_t self:netlink_kobject_uevent_socket bind;

Comment 1 Daniel Walsh 2009-09-08 11:28:57 UTC

*** This bug has been marked as a duplicate of bug 521372 ***


Note You need to log in before you can comment on or make changes to this bug.