Bug 521380 - setroubleshoot: SELinux is preventing prelink "remove_name" access on slashem.#prelink#.iWb1V2.
Summary: setroubleshoot: SELinux is preventing prelink "remove_name" access on sl...
Keywords:
Status: CLOSED DUPLICATE of bug 521375
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:6ed85c34892...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 10:19 UTC by Sebastiano M. Cossu
Modified: 2009-09-08 22:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 22:04:24 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-05 10:19:12 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing prelink "remove_name" access on slashem.#prelink#.iWb1V2.

Descrizione dettagliata:

[prelink has a permissive type (prelink_t). This access was not denied.]

SELinux denied access requested by prelink. It is not expected that this access
is required by prelink and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:prelink_t:s0-s0:c0.c1023
Contesto target               system_u:object_r:games_exec_t:s0
Oggetti target                slashem.#prelink#.iWb1V2 [ dir ]
Sorgente                      prelink
Percorso della sorgente       /usr/sbin/prelink
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        prelink-0.4.2-2.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.28-8.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.180.rc7.git4.fc12.i686 #1 SMP
                              Wed Aug 26 16:30:44 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   ven 28 ago 2009 03:15:14 CEST
Ultimo visto                  ven 28 ago 2009 03:15:14 CEST
ID locale                     f912d9ac-7dd4-4caa-87ed-908c07644888
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1251422114.110:32): avc:  denied  { remove_name } for  pid=9686 comm="prelink" name="slashem.#prelink#.iWb1V2" dev=dm-0 ino=50583 scontext=system_u:system_r:prelink_t:s0-s0:c0.c1023 tcontext=system_u:object_r:games_exec_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1251422114.110:32): arch=40000003 syscall=38 success=yes exit=0 a0=bfab90a0 a1=bfab90e0 a2=a243ad0 a3=bfab90e0 items=0 ppid=9680 pid=9686 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm="prelink" exe="/usr/sbin/prelink" subj=system_u:system_r:prelink_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= prelink_t ==============
allow prelink_t games_exec_t:dir remove_name;

Comment 1 Daniel Walsh 2009-09-08 22:04:24 UTC

*** This bug has been marked as a duplicate of bug 521375 ***


Note You need to log in before you can comment on or make changes to this bug.