Bug 521392 - setroubleshoot: SELinux is preventing the sa-learn from using potentially mislabeled files (bayes.lock.arekh.okg.15142).
Summary: setroubleshoot: SELinux is preventing the sa-learn from using potentiall...
Keywords:
Status: CLOSED DUPLICATE of bug 521391
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:68f03f59db5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 14:35 UTC by Nicolas Mailhot
Modified: 2009-09-08 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 22:11:34 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2009-09-05 14:35:13 UTC
The following was filed automatically by setroubleshoot:

Résumé:

SELinux is preventing the sa-learn from using potentially mislabeled files
(bayes.lock.(removed).15142).

Description détaillée:

[sa-learn has a permissive type (system_cronjob_t). This access was not denied.]

SELinux has denied sa-learn access to potentially mislabeled file(s)
(bayes.lock.(removed).15142). This means that SELinux will not allow sa-learn to
use these files. It is common for users to edit files in their home directory or
tmp directories and then move (mv) them to system directories. The problem is
that the files end up with the wrong file context which confined applications
are not allowed to access.

Autoriser l'accès:

If you want sa-learn to access this files, you need to relabel them using
restorecon -v 'bayes.lock.(removed).15142'. You might want to relabel the entire
directory using restorecon -R -v ''.

Informations complémentaires:

Contexte source               system_u:system_r:system_cronjob_t:s0-s0:c0.c1023
Contexte cible                system_u:object_r:spamc_home_t:s0
Objets du contexte            bayes.lock.(removed).15142 [ file ]
source                        sa-learn
Chemin de la source           /usr/bin/perl
Port                          <Inconnu>
Hôte                         (removed)
Paquetages RPM source         perl-5.10.0-77.fc12
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.6.26-8.fc12
Selinux activé               True
Type de politique             targeted
MLS activé                   True
Mode strict                   Enforcing
Nom du plugin                 home_tmp_bad_labels
Nom de l'hôte                (removed)
Plateforme                    Linux (removed) 2.6.31-0.138.rc5.git3.fc12.x86_64
                              #1 SMP Thu Aug 6 16:59:15 EDT 2009 x86_64 x86_64
Compteur d'alertes            1
Première alerte              sam. 05 sept. 2009 15:45:03 CEST
Dernière alerte              sam. 05 sept. 2009 15:45:03 CEST
ID local                      aa2b6fa6-558b-4cd2-ab6e-e651f1b9cbcd
Numéros des lignes           

Messages d'audit bruts        

node=(removed) type=AVC msg=audit(1252158303.648:205): avc:  denied  { link } for  pid=15142 comm="sa-learn" name="bayes.lock.(removed).15142" dev=dm-2 ino=70290 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:spamc_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252158303.648:205): arch=c000003e syscall=86 success=yes exit=0 a0=3fe2248 a1=3fde268 a2=7fe07dd5528b a3=7ffffe0a3b50 items=0 ppid=15141 pid=15142 auid=0 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=17 comm="sa-learn" exe="/usr/bin/perl" subj=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= system_cronjob_t ==============
allow system_cronjob_t spamc_home_t:file link;

Comment 1 Daniel Walsh 2009-09-08 22:11:34 UTC

*** This bug has been marked as a duplicate of bug 521391 ***


Note You need to log in before you can comment on or make changes to this bug.