Bug 521398 - setroubleshoot: SELinux is preventing the sa-learn from using potentially mislabeled files (/home/nim/.spamassassin/bayes_toks).
Summary: setroubleshoot: SELinux is preventing the sa-learn from using potentiall...
Keywords:
Status: CLOSED DUPLICATE of bug 521391
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:80bed2b27d7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 14:38 UTC by Nicolas Mailhot
Modified: 2009-09-08 22:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 22:15:20 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2009-09-05 14:38:18 UTC
The following was filed automatically by setroubleshoot:

Résumé:

SELinux is preventing the sa-learn from using potentially mislabeled files
(/home/nim/.spamassassin/bayes_toks).

Description détaillée:

[sa-learn has a permissive type (system_cronjob_t). This access was not denied.]

SELinux has denied sa-learn access to potentially mislabeled file(s)
(/home/nim/.spamassassin/bayes_toks). This means that SELinux will not allow
sa-learn to use these files. It is common for users to edit files in their home
directory or tmp directories and then move (mv) them to system directories. The
problem is that the files end up with the wrong file context which confined
applications are not allowed to access.

Autoriser l'accès:

If you want sa-learn to access this files, you need to relabel them using
restorecon -v '/home/nim/.spamassassin/bayes_toks'. You might want to relabel
the entire directory using restorecon -R -v '/home/nim/.spamassassin'.

Informations complémentaires:

Contexte source               system_u:system_r:system_cronjob_t:s0-s0:c0.c1023
Contexte cible                unconfined_u:object_r:spamc_home_t:s0
Objets du contexte            /home/nim/.spamassassin/bayes_toks [ file ]
source                        sa-learn
Chemin de la source           /usr/bin/perl
Port                          <Inconnu>
Hôte                         (removed)
Paquetages RPM source         perl-5.10.0-82.fc12
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.6.30-2.fc12
Selinux activé               True
Type de politique             targeted
MLS activé                   True
Mode strict                   Enforcing
Nom du plugin                 home_tmp_bad_labels
Nom de l'hôte                (removed)
Plateforme                    Linux (removed) 2.6.31-0.203.rc8.git2.fc12.x86_64
                              #1 SMP Fri Sep 4 21:33:05 EDT 2009 x86_64 x86_64
Compteur d'alertes            4
Première alerte              sam. 05 sept. 2009 15:45:03 CEST
Dernière alerte              sam. 05 sept. 2009 16:15:02 CEST
ID local                      927be80c-9196-4b32-b4e2-750aecd01d03
Numéros des lignes           

Messages d'audit bruts        

node=(removed) type=AVC msg=audit(1252160102.831:45): avc:  denied  { read } for  pid=1914 comm="sa-learn" name="bayes_toks" dev=dm-2 ino=70378 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:spamc_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1252160102.831:45): avc:  denied  { open } for  pid=1914 comm="sa-learn" name="bayes_toks" dev=dm-2 ino=70378 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:spamc_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252160102.831:45): arch=c000003e syscall=2 success=yes exit=3 a0=2b1a260 a1=0 a2=0 a3=7fff4f7fbe30 items=0 ppid=1913 pid=1914 auid=0 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=2 comm="sa-learn" exe="/usr/bin/perl" subj=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= system_cronjob_t ==============
allow system_cronjob_t spamc_home_t:file { read open };

Comment 1 Daniel Walsh 2009-09-08 22:15:20 UTC

*** This bug has been marked as a duplicate of bug 521391 ***


Note You need to log in before you can comment on or make changes to this bug.