Bug 521424 - pulseaudio ( or alsa ) almost crashed system
Summary: pulseaudio ( or alsa ) almost crashed system
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 18:09 UTC by cornel panceac
Modified: 2009-09-07 23:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-07 16:10:23 UTC


Attachments (Terms of Use)
the /var/log/messages output during 'crash' (13.99 KB, text/plain)
2009-09-05 18:09 UTC, cornel panceac
no flags Details
/var/log/messages filtered by pulseaudio (31.15 KB, text/plain)
2009-09-07 18:24 UTC, cornel panceac
no flags Details

Description cornel panceac 2009-09-05 18:09:28 UTC
Created attachment 359875 [details]
the /var/log/messages output during 'crash'

Description of problem:

while i was watching a movie with vlc, the system frozed for a while and then vlc got killed and the system recovered.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
what i've seen in /var/log/messages is attached

Expected results:


Additional info:

Comment 1 Lennart Poettering 2009-09-07 14:31:00 UTC
Apparently the OOM killer became invoked and killed VLC because it appeared to be the memory hogger. Why do you think this is a problem in PA or ALSA?

Hm, is VLC even packaged in fedora? I'd like to reassign this to VLC but I see now pkg for it?

Comment 2 cornel panceac 2009-09-07 14:47:30 UTC
(In reply to comment #1)
> Apparently the OOM killer became invoked and killed VLC because it appeared to
> be the memory hogger. Why do you think this is a problem in PA or ALSA?

because the log says 

pulseaudio[2339]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.

> 
> Hm, is VLC even packaged in fedora? I'd like to reassign this to VLC but I see
> now pkg for it?  

no, vlc is not packaged by fedora. if this is not a pulseaudio bug, and if it's not alsa-drivers bug, then we should close this bug.

Comment 3 cornel panceac 2009-09-07 15:14:18 UTC
hmm, i was wondering, whatever (user) processes are running, they are not supposed to (almost) kill the system, right? then why 2 GB were not enough for: deluge + firefox + k3b + vlc ? maybe it's a kernel bug after all ...

Comment 4 Lennart Poettering 2009-09-07 16:09:02 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Apparently the OOM killer became invoked and killed VLC because it appeared to
> > be the memory hogger. Why do you think this is a problem in PA or ALSA?
> 
> because the log says 
> 
> pulseaudio[2339]: alsa-util.c: Most likely this is a bug in the ALSA driver
> 'snd_hda_intel'. Please report this issue to the ALSA developers.

Nah, this is unrelated.

> no, vlc is not packaged by fedora. if this is not a pulseaudio bug, and if it's
> not alsa-drivers bug, then we should close this bug.  

Probably.

Comment 5 Lennart Poettering 2009-09-07 16:10:23 UTC
(In reply to comment #3)
> hmm, i was wondering, whatever (user) processes are running, they are not
> supposed to (almost) kill the system, right? then why 2 GB were not enough for:
> deluge + firefox + k3b + vlc ? maybe it's a kernel bug after all ...  

Nah, something is leaking memory. The kernel figured it was VLC. Which is why I think this should be reassigned to it.

Closing now, as you suggested.

Please file a bug against VLC upstream or wherever you got your packages from.

Comment 6 cornel panceac 2009-09-07 16:46:31 UTC
maybe it's unrelated, but trying to listen some music (mp3s) with mplayer,xmms,or rhythmbox on another system (thinkpad x40) leaded to many pulseaudio messages on /var/log/messages while the system was often "freezing". i eventually give up listening music. this system was not updated, and unfortunately kernel will not be updated since updating kernel will leave me without wireless. i'll add the details after updating everything else and (of course?) rebooting.

Comment 7 cornel panceac 2009-09-07 18:24:54 UTC
Created attachment 360010 [details]
/var/log/messages filtered by pulseaudio

that's the /var/log/messages (filtered) from thinkpad x40, before and after update.

maybe there was a bug in alsalib, after update i can play the same music i was unable to play earlier.

thank you very much for assistance.

Comment 8 Lennart Poettering 2009-09-07 23:18:53 UTC
snd_pcm_avail() returned a value that is exceptionally large: 4294935988 bytes (24347709 ms).

Your audio driver is (was?) broken. See bug 506075 for details. If this problem is fixed now, maybe you updated your kernel?


Note You need to log in before you can comment on or make changes to this bug.