Bug 521453 - F12 xorg radeon hd 2600xt
Summary: F12 xorg radeon hd 2600xt
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-05 22:31 UTC by matti aarnio
Modified: 2009-09-17 23:09 UTC (History)
1 user (show)

Fixed In Version: xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.x86_64
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 23:09:43 UTC


Attachments (Terms of Use)
one of Xorg.0.log files (71.55 KB, text/plain)
2009-09-05 22:31 UTC, matti aarnio
no flags Details
one of Xorg.0.log files (71.42 KB, text/plain)
2009-09-05 22:33 UTC, matti aarnio
no flags Details
one of Xorg.0.log files (71.49 KB, text/plain)
2009-09-05 22:34 UTC, matti aarnio
no flags Details

Description matti aarnio 2009-09-05 22:31:40 UTC
Created attachment 359886 [details]
one of Xorg.0.log files

Description of problem:
  X-service is flakey, crash in 1 minute to a few hours
   - crash with internal SEGV
   - crash with "EQ overflowing. ..." 

Version-Release number of selected component (if applicable):
  xorg-x11-server-Xorg-1.6.99-45.20090903.fc12.x86_64
  along with xorg-x11-drv-ati-6.13.0-0.2.20090821gitb1b77a4d6.fc12.x86_64

How reproducible:
  sometimes I need to reboot the Linux every 3-4 minutes to get
  a bit onwards at my normal computer use,
  Sometimes I get hours of service.  Some keying patterns are more
  prone to provoke a crash.

Steps to Reproduce:
0. have AMD X2 or equivalent, ATI Radeon HD 2600 card
1. Configure system to start on text console
2. login as user, then "startx > x.log 2>&1 &"
3. use the system, especially repeated and quick poking of left control key
   seems to be able to introduce the data corruption leading to SEGV, and/or
   to cause the "EQ overflowing"

Actual results:
  X server crashes to text console, or more often becomes hard wedged.
  Ctrl-Alt-SysReq keys do work, thus my usual sequence is E, S, U, B...

Expected results:
  Nice stable X service.  With all accelerations...

Additional info:
  Bleeding edge Rawhide.
  Studying the cores dropped by X server gives an impression of memory
  corruption being the root of it.  I have a bunch of Xorg.0.log copies,
  which are showing these symptoms.
  Other cases (wedging the X server) log "EQ overflowing. The server is
  probably stuck in an infinite loop." as last thing before groaking.

Comment 1 matti aarnio 2009-09-05 22:33:33 UTC
Created attachment 359887 [details]
one of Xorg.0.log files

Comment 2 matti aarnio 2009-09-05 22:34:58 UTC
Created attachment 359888 [details]
one of Xorg.0.log files

Comment 3 matti aarnio 2009-09-06 16:52:42 UTC
I did submit this on freedesktop as well:
  https://bugs.freedesktop.org/show_bug.cgi?id=23742

Notable thing is that when I disabled gnome-mouse-setting "Locate Pointer"
(which draws concentric rings on mouse upon toggling the control key), the
problem disappeared.  (Or became very difficult to induce.)

Comment 4 matti aarnio 2009-09-10 09:08:18 UTC
This apparently got fixed in latest xorg-x11-dev-ati  driver (or X core).
At least I can no longer induce it by poking the left control while
"Locate Pointer" is active.

Following are OK:

xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.x86_64

Comment 5 matti aarnio 2009-09-10 09:08:18 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
This apparently got fixed in latest xorg-x11-dev-ati  driver (or X core).
At least I can no longer induce it by poking the left control while "Locate Pointer" is active.

Comment 6 matti aarnio 2009-09-17 23:09:43 UTC
Deleted Release Notes Contents.

Old Contents:
This apparently got fixed in latest xorg-x11-dev-ati  driver (or X core).
At least I can no longer induce it by poking the left control while "Locate Pointer" is active.


Note You need to log in before you can comment on or make changes to this bug.