Bug 521461 - Compiz fails to work on Fedora 12 Rawhide
Summary: Compiz fails to work on Fedora 12 Rawhide
Keywords:
Status: CLOSED DUPLICATE of bug 522857
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 522603 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 07:35 UTC by Pramod Dematagoda
Modified: 2009-09-18 04:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-18 04:26:39 UTC


Attachments (Terms of Use)
Xorg log metacity -> mutter -> compiz (24.58 KB, application/octet-stream)
2009-09-07 17:56 UTC, Steven Usdansky
no flags Details

Description Pramod Dematagoda 2009-09-06 07:35:24 UTC
Description of problem: When trying to replace metacity with compiz on Fedora 12(Rawhide) the screen just keeps flickering(or just acts plain weird if run through the terminal) until compiz is stopped.


Version-Release number of selected component (if applicable): 0.8.2


How reproducible:
1) Open a terminal and execute "compiz --replace".

2) Go to System->Preferences->Desktop Effects and select "Compiz".


Steps to Reproduce:
1. Open a terminal.
2. Enter "compiz --replace".
3. Press enter.
  
Actual results:
1) With the terminal, the flickering is not present, but the whole desktop just freezes(the video freezes, you can still move the mouse and input stuff in).

2) With Desktop Effects, the screen keeps flickering unstoppably.


Expected results: Compiz should run normally and show some cool desktop effects.


Additional info:
This is on an Intel 945GM VGA card.

Also this output is obtained when running compiz through the terminal:-
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

Additionally, mutter(the compositing window manager for gnome-shell) works just fine.

Comment 1 Steven Usdansky 2009-09-07 17:51:19 UTC
Got the following when replacing metacity with mutter, but mutter seems to work ok. Ref to vblank_mode is similar, if not identical to that seen when trying to replace metacity with compiz. 

~$ mutter --replace

(mutter:9156): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(mutter:9156): atk-bridge-WARNING **: IOR not set.

(mutter:9156): atk-bridge-WARNING **: Could not locate registry
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.

Comment 2 Steven Usdansky 2009-09-07 17:56:13 UTC
Created attachment 360009 [details]
Xorg log metacity -> mutter -> compiz

Backspace and left-arrow keys not generating proper display at the moment; will send anyway

Comment 3 Michal Nowak 2009-09-10 19:57:24 UTC
*** Bug 522603 has been marked as a duplicate of this bug. ***

Comment 4 Michal Nowak 2009-09-10 20:00:32 UTC
I have the same problem with flickering on Intel 855 GM but I noticed that compiz SEGFAULTed silently background. Here come's the backtrace:

Core was generated by `compiz --ignore-desktop-hints --always-swap glib gconf gnomecompat --replace'.
Program terminated with signal 11, Segmentation fault.
#0  0x003128a0 in ?? ()

Thread 1 (Thread 10046):
#0  0x003128a0 in ?? ()
No symbol table info available.
#1  0x004b9508 in __cxa_finalize (d=0x9141c0) at cxa_finalize.c:56
        check = 2
        cxafn = <value optimized out>
        cxaarg = <value optimized out>
        f = 0x603cd8
        funcs = <value optimized out>
#2  0x0083aa55 in __do_global_dtors_aux () from /lib/libglib-2.0.so.0.2106.0
No symbol table info available.
#3  0x008b8650 in _fini () from /lib/libglib-2.0.so.0.2106.0
No symbol table info available.
#4  0x006d0a86 in _dl_close_worker (map=0x9374c78) at dl-close.c:271
        imap = 0x9374f00
        i = 38
        dl_close_state = pending
        nsid = 0
        ns = 0x6dd000
        any_tls = false
        nloaded = 40
        idx = <value optimized out>
        __PRETTY_FUNCTION__ = "_dl_close_worker"
        done_index = <value optimized out>
        unload_any = true
        scope_mem_left = false
        unload_global = 0
        first_loaded = 31
        r = 0x901639c
        tls_free_start = 151086064
        tls_free_end = <value optimized out>
#5  0x006d1527 in _dl_close (_map=0x9374c78) at dl-close.c:742
        __PRETTY_FUNCTION__ = "_dl_close"
#6  0x00988cd4 in dlclose_doit (handle=0x9374c78) at dlclose.c:37
No locals.
#7  0x006cb4a6 in _dl_catch_error (objname=<value optimized out>, errstring=<value optimized out>, 
    mallocedp=<value optimized out>, operate=0x988cb0 <dlclose_doit>, args=0x9374c78) at dl-error.c:178
        errcode = <value optimized out>
        old = 0x0
        c = {objname = 0x0, errstring = 0x0, malloced = 43, env = {{__jmpbuf = {7196612, 7195776, 150990960, -1076857896, 
                -1076858112, 7124105}, __mask_was_saved = 151321216, __saved_mask = {__val = {2024180, 2018807, 134753440, 
                  0, 2024180, 6303732, 157953744, 0, 6303732, 5228069, 157953744, 3218109320, 5733270, 157953744, 13515521, 
                  1, 104, 5228069, 0, 152656592, 13515712, 151274040, 0, 3218109416, 13141496, 0, 152656600, 7123686, 
                  154619440, 0, 134753440, 2360}}}}}
#8  0x0098903c in _dlerror_run (operate=<value optimized out>, args=<value optimized out>) at dlerror.c:164
        result = 0x8fff070
#9  0x00988d0a in __dlclose (handle=0x603cc8) at dlclose.c:48
No locals.
#10 0x0806f9d4 in unloadPlugin (p=0x9045208) at plugin.c:546
No locals.
#11 0x08051ec0 in finiCore () at core.c:230
        p = 0x0
#12 0x08051880 in main (argc=7, argv=0xbfd07994) at main.c:480
        ctx = {offset = 2806, pluginData = 0x8e9b008 "XSMP", textureFilterData = 0x0, refreshRateData = 0x0}
        displayName = 0x0
        plugin = {0xbfd09abf "glib", 0xbfd09ac4 "gconf", 0xbfd09aca "gnomecompat", 0xb7f80af8 "", 0x0, 0x0, 
          0x1 <Address 0x1 out of bounds>, 0x384 <Address 0x384 out of bounds>, 0xb7f7e530 "U\204\036", 0xb7f827f0 "", 
          0x1e72c0 "strstr", 0x496e60 "", 0x1e60c4 "\234", 0x1 <Address 0x1 out of bounds>, 0x6dcfc4 "\374\016\002", 
          0xbfd075ec "", 0xb7f80cb0 "<\332m", 0xbfd075c0 "\306T\037", 0x6c6a60 "\203", <incomplete sequence \370>, 
          0xbfd075b0 "\360'\370\267\300u\375\240P", 0x1e60c4 "\234", 0xbfd075a4 "\340\025I", 0x6dda3c "\360\031\001\t#", 
          0x0, 0xb7f7e530 "U\204\036", 0x1 <Address 0x1 out of bounds>, 0x0, 0x1 <Address 0x1 out of bounds>, 
          0xb7f80af8 "", 0xb7f81000 "", 0xbfd07320 "\360>8\t", 0x6dcfc4 "\374\016\002", 0x1 <Address 0x1 out of bounds>, 
          0xb7f82d28 "", 0xbfd07530 "\370\n", <incomplete sequence \370\267>, 0x6c9840 "U\271\001", 0xbfd07774 "", 0x0, 
          0xbfd075ec "", 0xbfd075a4 "\340\025I", 0xbfd075b0 "\360'\370\267\300u\375\240P", 0x0, 0xbfd07540 "\001", 
          0xb7f80af8 "", 0x1e72c0 "strstr", 
          0x6d0002 "\330\205\300\017\205\247\376\377\377\215F\001\211E\340\351\005\377\377\377f\220\061\322\061\311\350\377\314\377\377\213\227`\001", 0x6cc23d "\205\300u\347\203\304\b\270\001", 
          0x1e98e0 "U\211\345\203\354\b\211\034$\213U\f\211|$\004\350K\372\377\377\201\303\377\066\001", 
          0x10000004 <Address 0x10000004 out of bounds>, 0x6dcfc4 "\374\016\002", 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 
          0x4915e0 "\030J", 0x4a0f30 "\201\303\304 \026", 0x602ff4 "|\215\027", 0xb7f827f0 "", 0xbfd075c0 "\306T\037", 
          0x50a0fd "\353U1\345WV\276\377\377\377\377\201\354<\004", 0x0, 0x1f54c6 "MP", 
          0x50abda "\205\300\017\205n\374\377\377\213E\344\205\300\017\204c\374\377\377\213M\340\071M\360vZ\213u}\354\213M\320\017\266\026:\024\071\017\205\227", 0xbfd076fa "SMP Sat Sep 5 21:01:10 EDT 2009", 0x0, 
          0x3 <Address 0x3 out of bounds>, 0x1f54c7 "P", 0x3 <Address 0x3 out of bounds>, 0x0, 
          0x3 <Address 0x3 out of bounds>, 0xbfd076fb "MP Sat Sep 5 21:01:10 EDT 2009", 0x1f54c6 "MP", 0x0, 
          0xbfd076fa "SMP Sat Sep 5 21:01:10 EDT 2009", 0x1 <Address 0x1 out of bounds>, 0x3 <Address 0x3 out of bounds>, 
          0x1f54c5 "SMP", 0xbfd076fa "SMP Sat Sep 5 21:01:10 EDT 2009", 0x3 <Address 0x3 out of bounds>, 
          0x1fcff4 "\264~\001", 0xbfd076f7 "#1 SMP Sat Sep 5 21:01:10 EDT 2009", 0x6dd000 "\340\330m", 
          0xbfd078e0 "\240n\a\b", 0x1e9838 "\205\300\017\225\300\017\266\300\211\203\304!", 
          0xbfd076f7 "#1 SMP Sat Sep 5 21:01:10 EDT 2009", 0x1f54c5 "SMP", 0x0, 0x6bc334 "5\001", 0x0, 
          0xbfd07838 "\360'\370\267\332\307\004\b`nI", 0x756e694c <Address 0x756e694c out of bounds>, 
          0x78 <Address 0x78 out of bounds>, 0x0 <repeats 14 times>, 0x73736100 <Address 0x73736100 out of bounds>, 
          0x6d61 <Address 0x6d61 out of bounds>, 0x0 <repeats 14 times>, 0x2e320000 <Address 0x2e320000 out of bounds>, 
          0x31332e36 <Address 0x31332e36 out of bounds>, 0x322e302d <Address 0x322e302d out of bounds>, 
          0x722e3430 <Address 0x722e3430 out of bounds>, 0x662e3963 <Address 0x662e3963 out of bounds>, 
          0x2e323163 <Address 0x2e323163 out of bounds>, 0x36383669 <Address 0x36383669 out of bounds>, 0x0, 0x0, 0x0, 0x0, 
          0x0, 0x0, 0x0, 0x0, 0x0, 0x23000000 <Address 0x23000000 out of bounds>, 
          0x4d532031 <Address 0x4d532031 out of bounds>, 0x61532050 <Address 0x61532050 out of bounds>, 
          0x65532074 <Address 0x65532074 out of bounds>, 0x20352070 <Address 0x20352070 out of bounds>, 
          0x303a3132 <Address 0x303a3132 out of bounds>, 0x30313a31 <Address 0x30313a31 out of bounds>, 
          0x54444520 <Address 0x54444520 out of bounds>, 0x30303220 <Address 0x30303220 out of bounds>, 
          0x39 <Address 0x39 out of bounds>, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 
          0x36383669 <Address 0x36383669 out of bounds>, 0x0 <repeats 15 times>, 
          0x6c60ae "\213M\340\205\300u3\203\304$\211\360[^_]\213G \213W\034\003\006\211T$\004\211\004$\350\314", <incomplete sequence \344>, 0x49c74f "GLIBC_2.0", 0x804ec58 "GLIBC_2.0", 0x0, 0x0, 0xb7f7f6f8 "X\354\004\b\020ii\r", 
          0x2 <Address 0x2 out of bounds>, 0x6cc23d "\205\300u\347\203\304\b\270\001", 0x804c5ec "libc.so.6", 
          0xb7f827c4 "libm.so.6", 0x6dcfc4 "\374\016\002", 
          0x48db98 "/N=\366\316\030L\017\371\304-\"\233|\370\"\233|%\301\324\361\354\373\300=\260\"\225\303\070\307\031u\377\001\304\022\311BY\020\334\317w\035\rG\336\315%\265V1\375\307r1\035\a;\372L\214\t)\020\t~\222\034\070\265\357\060j\335\371{\004\\H\261\034\240\002\352\331\017\071\265\357\060X?\227|\030\034s\354T\200\314sc\002;H\205\033\066\rf\375\062v\340\247K#\217\326\036h\233\243\230\313\362\234\002Y1\n\264\006\337\275\350e\235J\032\223\250P\265\250\020\205)%~\016|\030\271\321\070\a\221\222\376\206\357\246:V\323\361I\265$\202\241\067\344Qho", <incomplete sequence \354>..., 
          0xe <Address 0xe out of bounds>, 0xbfd07858 "\024y`jl", 
          0x6c6869 "\205\300u\027\213\006\353}\224\351\206\372\377\377\213u\270\211}\224\351\061\372\377\377\213u\270\211}\224\351p\372\377\377\213U\214\211\024$\377\223\030\b", 0x0, 0x0, 0xbfd077ec "\016", 
          0x4b7510 "\203", <incomplete sequence \370>, 0xbfd07818 "}", 0x5c1eb8 "}\b@\006", 0x0, 0x0, 0x0, 
          0x6dde20 "0\336m", 0x5c1eb8 "}\b@\006", 0x2b <Address 0x2b out of bounds>, 
          0x2c04307d <Address 0x2c04307d out of bounds>, 0x6 <Address 0x6 out of bounds>, 0xe <Address 0xe out of bounds>, 
          0x50c5c1 "\205\300t\020\017\266P\003\017\266\312\071\371tp\200\372\006tK\301\356\b\205\366t\034\211\360%\377", 
          0xbfd07818 "}", 0x48dda0 "", 0x6d833c "symbol=%s;  lookup in file=%s [%lu]\n", 0x496640 "\225,", 
          0x50c320 "U\211\345\213E\f\213M\b\017\266\020\061\300\070\021t\005\031\300\203\310\001]\264&", 
          0x7b1ea71 <Address 0x7b1ea71 out of bounds>, 0xe <Address 0xe out of bounds>, 
          0xb7f7f694 "\360'\370\267\210*\370\267(-", <incomplete sequence \370\267>...}
        i = <value optimized out>
        nPlugin = 3
        disableSm = 0
        clientId = 0x0
        refreshRateArg = 0x0

Comment 5 Adam Williamson 2009-09-18 04:26:39 UTC

*** This bug has been marked as a duplicate of bug 522857 ***


Note You need to log in before you can comment on or make changes to this bug.