Bug 521470 - YUM Extender Start Error
Summary: YUM Extender Start Error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 10
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 09:17 UTC by Jwalant Natvarlal Soneji
Modified: 2009-10-01 09:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-01 09:23:57 UTC


Attachments (Terms of Use)

Description Jwalant Natvarlal Soneji 2009-09-06 09:17:30 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Click F and find Yum Extender icon
2.Click on the icon
3.Enter password for root login
4.Got the error
  
Actual results:
It should show the GUI with latest updates if any

Expected results:
A popup message box with following message:
###
Error Type: <type 'exceptions.TypeError'> 
Error Value: rpmdb open failed 
  File : /usr/share/yumex/yumex.py , line 739, in <module>
    mainApp = YumexApplication() 
  File : /usr/share/yumex/yumex.py , line 420, in __init__
    self.yumbase = YumexYumHandler(self.getRecentTime(),self.settings,self.progress,self.ui.main,self.yumexOptions._optparser) 
  File : /usr/share/yumex/yumapi.py , line 51, in __init__
    optparser = parser ) 
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 170, in doConfigSetup
    return self.conf 
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 652, in <lambda>
    conf = property(fget=lambda self: self._getConfig(), 
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 239, in _getConfig
    self._conf = config.readMainConfig(startupconf) 
  File : /usr/lib/python2.5/site-packages/yum/config.py , line 794, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg) 
  File : /usr/lib/python2.5/site-packages/yum/config.py , line 867, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg) 
###


Additional info:
Since the YUM Extender is installed, the "YUM update" command on terminal is also not working.

Comment 1 Tim Lauridsen 2009-09-07 06:29:43 UTC
This is a problem with your rpm db

Try to run these commands as root to fix it.

rm -f /var/lib/rpm/__db* 
rpm --rebuilddb 

And then yum and yumex should work again.


Note You need to log in before you can comment on or make changes to this bug.