Bug 521504 - The message "Checking for new repos for mirrors" is incomprehensibly ambiguous.
The message "Checking for new repos for mirrors" is incomprehensibly ambiguous.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-06 11:16 EDT by Peter Trenholme
Modified: 2014-01-21 18:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 12:03:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2009-09-06 11:16:49 EDT
Description of problem:
The message "Checking for new repos for mirrors" can be interpreted in so many different ways that it is incomprehensible.

Version-Release number of selected component (if applicable):
$ yum --version
3.2.24
  Installed: rpm-4.7.1-4.fc12.x86_64 at 2009-09-03 19:26
  Built    : Fedora Project at 2009-08-14 17:03
  Committed: Jesse Keating <jkeating@redhat.com> at 2009-08-14 12:00

  Installed: yum-3.2.24-2.fc12.noarch at 2009-09-05 15:35
  Built    : Fedora Project at 2009-09-03 20:59
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2009-09-03 12:00

  Installed: yum-metadata-parser-1.1.2-14.fc12.x86_64 at 2009-09-03 19:24
  Built    : Fedora Project at 2009-08-18 16:30
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2009-08-18 12:00


How reproducible:
Every time

Steps to Reproduce:
1.Start yum
2.
3.
  
Actual results:
Message "Checking for new repos for mirrors" displayed

Expected results:
Something that makes some sense should be displayed

Additional info:
"Checking for new repos for mirrors" could mean:

Checking any new repositories for new mirrors
-or-

Checking for new repositories or mirrors
-or- (since a new repository would have been specified in repos.d)

Checking for new mirrors
-or-

something else I can't guess.

Anyhow, next time the code is changed, replacing the message with something that makes a little sense would be useful.
Comment 1 seth vidal 2009-09-06 11:47:12 EDT
This string, afaict, does not appear anywhere in yum.

Can you cut and paste it and its context?

Thanks
Comment 2 Peter Trenholme 2009-09-06 13:10:11 EDT
The message has been around for a while. (I reported it to rawhide so it could be improved in F12. It's, as I said, a very low impact issue.)

I'm on F11 right now, but here's a typical run: (I isolated the first occurrence with a dashes, not normally in the output.)

$ sudo yum update
[sudo] password for Peter:        
Loaded plugins: allowdowngrade, auto-update-debuginfo, dellsysidplugin2, fastestmirror, keys, merge-conf,
              : presto, upgrade-helper, verify                                                           
Found 24 installed debuginfo package(s)                                                                  
Enabling fedora-debuginfo: Fedora 11 - x86_64 - Debug                                                    
Loading mirror speeds from cached hostfile                                                               
updates/metalink                                                                    |  16 kB     00:00     
 * fedora: mirror.web-ster.com                                                                             
 * fedora-debuginfo: linux.mirrors.es.net                                                                  
 * rpmfusion-free: mirror.web-ster.com                                                                     
 * rpmfusion-free-updates: mirror.web-ster.com
 * rpmfusion-nonfree: mirror.web-ster.com
 * rpmfusion-nonfree-updates: mirror.web-ster.com
 * updates: mirror.web-ster.com
Reading repository metadata in from local files
Enabling rpmfusion-nonfree-debuginfo: RPM Fusion for Fedora 11 - Nonfree - Debug
---------------------------------------
Checking for new repos for mirrors
---------------------------------------
 * rpmfusion-nonfree-debuginfo: mirror.web-ster.com
Reading repository metadata in from local files
Enabling rpmfusion-free-updates-debuginfo: RPM Fusion for Fedora 11 - Free - Updates Debug
Checking for new repos for mirrors
 * rpmfusion-free-updates-debuginfo: mirror.web-ster.com
Reading repository metadata in from local files
rpmfusion-free-updates-debuginfo                                                    | 2.7 kB     00:00
Enabling rpmfusion-free-debuginfo: RPM Fusion for Fedora 11 - Free - Debug
Checking for new repos for mirrors
 * rpmfusion-free-debuginfo: mirror.web-ster.com
Reading repository metadata in from local files
Enabling updates-debuginfo: Fedora 11 - x86_64 - Updates - Debug
Checking for new repos for mirrors
updates-debuginfo/metalink                                                          |  12 kB     00:00
 * updates-debuginfo: linux.mirrors.es.net
Reading repository metadata in from local files
Enabling rpmfusion-nonfree-updates-debuginfo: RPM Fusion for Fedora 11 - Nonfree - Updates Debug
Checking for new repos for mirrors
 * rpmfusion-nonfree-updates-debuginfo: mirror.web-ster.com
Reading repository metadata in from local files
rpmfusion-nonfree-updates-debuginfo                                                 | 2.7 kB     00:00
Checking for new repos for mirrors
adobe-linux-i386                                                                    |  951 B     00:00
rpmfusion-free-updates                                                              | 3.8 kB     00:00
rpmfusion-nonfree-updates                                                           | 3.8 kB     00:00
Setting up Update Process
No Packages marked for Update
Comment 3 seth vidal 2009-09-06 13:59:06 EDT
this is coming out of the fastest-mirror plugin and is kind a legit message there.

It means it is checking to see if there are any repos which are not cached which are using mirrors.

Note You need to log in before you can comment on or make changes to this bug.