Bug 521537 - setroubleshoot: SELinux is preventing prelink "remove_name" access on slashem.#prelink#.6VX1KB.
Summary: setroubleshoot: SELinux is preventing prelink "remove_name" access on sl...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:318f3607ab6...
: 521536 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 20:48 UTC by Sebastiano M. Cossu
Modified: 2009-09-07 11:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-07 11:16:39 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-06 20:48:41 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing prelink "remove_name" access on slashem.#prelink#.6VX1KB.

Descrizione dettagliata:

[prelink has a permissive type (prelink_t). This access was not denied.]

SELinux denied access requested by prelink. It is not expected that this access
is required by prelink and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:prelink_t:s0-s0:c0.c1023
Contesto target               system_u:object_r:games_exec_t:s0
Oggetti target                slashem.#prelink#.6VX1KB [ dir ]
Sorgente                      prelink
Percorso della sorgente       /usr/sbin/prelink
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        prelink-0.4.2-2.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.199.rc8.git2.fc12.i686 #1 SMP
                              Wed Sep 2 21:10:11 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   dom 06 set 2009 12:42:31 CEST
Ultimo visto                  dom 06 set 2009 12:42:31 CEST
ID locale                     7117a8db-dc1a-437c-954a-06cf11ba4d06
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252233751.693:38): avc:  denied  { remove_name } for  pid=4533 comm="prelink" name="slashem.#prelink#.6VX1KB" dev=dm-0 ino=21179 scontext=system_u:system_r:prelink_t:s0-s0:c0.c1023 tcontext=system_u:object_r:games_exec_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252233751.693:38): arch=40000003 syscall=38 success=yes exit=0 a0=bfcb10c0 a1=bfcb1100 a2=9b4bd48 a3=bfcb1100 items=0 ppid=4524 pid=4533 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="prelink" exe="/usr/sbin/prelink" subj=system_u:system_r:prelink_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= prelink_t ==============
allow prelink_t games_exec_t:dir remove_name;

Comment 1 Daniel Walsh 2009-09-07 11:16:39 UTC
Fixed in selinux-policy-3.6.30-5.fc12.noarch

Comment 2 Daniel Walsh 2009-09-07 11:17:08 UTC
*** Bug 521536 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.