Bug 521563 - setroubleshoot: SELinux is preventing the wine32 from using potentially mislabeled files (c:).
Summary: setroubleshoot: SELinux is preventing the wine32 from using potentially ...
Keywords:
Status: CLOSED DUPLICATE of bug 521564
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0e51c7815f3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 22:49 UTC by Sebastiano M. Cossu
Modified: 2009-09-07 11:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-07 11:03:26 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-06 22:49:31 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing the wine32 from using potentially mislabeled files (c:).

Descrizione dettagliata:

[wine32 has a permissive type (wine_t). This access was not denied.]

SELinux has denied wine32 access to potentially mislabeled file(s) (c:). This
means that SELinux will not allow wine32 to use these files. It is common for
users to edit files in their home directory or tmp directories and then move
(mv) them to system directories. The problem is that the files end up with the
wrong file context which confined applications are not allowed to access.

Abilitazione accesso in corso:

If you want wine32 to access this files, you need to relabel them using
restorecon -v 'c:'. You might want to relabel the entire directory using
restorecon -R -v '<Unknown>'.

Informazioni aggiuntive:

Contesto della sorgente       unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Contesto target               unconfined_u:object_r:user_home_t:s0
Oggetti target                c: [ lnk_file ]
Sorgente                      wine32
Percorso della sorgente       /usr/bin/wine-preloader
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        wine-core-1.1.29-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   home_tmp_bad_labels
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   lun 07 set 2009 00:35:58 CEST
Ultimo visto                  lun 07 set 2009 00:35:58 CEST
ID locale                     c77b7675-d675-4578-89d2-9cf83a707853
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252276558.733:91): avc:  denied  { create } for  pid=6058 comm="wine32" name="c:" scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=lnk_file

node=(removed) type=SYSCALL msg=audit(1252276558.733:91): arch=40000003 syscall=83 success=yes exit=0 a0=6838bab8 a1=6838baaa a2=6839d448 a3=7deaeef8 items=0 ppid=1 pid=6058 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="wine32" exe="/usr/bin/wine-preloader" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t user_home_t:lnk_file create;

Comment 1 Daniel Walsh 2009-09-07 11:03:26 UTC

*** This bug has been marked as a duplicate of bug 521564 ***


Note You need to log in before you can comment on or make changes to this bug.