Bug 521564 - setroubleshoot: SELinux is preventing the wineserver from using potentially mislabeled files (.wine).
Summary: setroubleshoot: SELinux is preventing the wineserver from using potentia...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:b4637edf4e8...
: 521558 521561 521562 521563 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 22:50 UTC by Sebastiano M. Cossu
Modified: 2009-09-07 11:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-07 11:02:08 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-06 22:50:05 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing the wineserver from using potentially mislabeled files
(.wine).

Descrizione dettagliata:

[wineserver has a permissive type (wine_t). This access was not denied.]

SELinux has denied wineserver access to potentially mislabeled file(s) (.wine).
This means that SELinux will not allow wineserver to use these files. It is
common for users to edit files in their home directory or tmp directories and
then move (mv) them to system directories. The problem is that the files end up
with the wrong file context which confined applications are not allowed to
access.

Abilitazione accesso in corso:

If you want wineserver to access this files, you need to relabel them using
restorecon -v '.wine'. You might want to relabel the entire directory using
restorecon -R -v '.wine'.

Informazioni aggiuntive:

Contesto della sorgente       unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Contesto target               unconfined_u:object_r:user_home_t:s0
Oggetti target                .wine [ dir ]
Sorgente                      wineserver
Percorso della sorgente       /usr/bin/wineserver
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        wine-core-1.1.29-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   home_tmp_bad_labels
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              2
Primo visto                   lun 07 set 2009 00:35:58 CEST
Ultimo visto                  lun 07 set 2009 00:35:58 CEST
ID locale                     d2482606-bb70-45e4-b75d-dfdc15967d09
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252276558.748:92): avc:  denied  { read } for  pid=6062 comm="wineserver" name=".wine" dev=dm-0 ino=163956 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252276558.748:92): avc:  denied  { open } for  pid=6062 comm="wineserver" name=".wine" dev=dm-0 ino=163956 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252276558.748:92): arch=40000003 syscall=5 success=yes exit=3 a0=808cf51 a1=8000 a2=0 a3=96b74d8 items=0 ppid=6058 pid=6062 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="wineserver" exe="/usr/bin/wineserver" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t user_home_t:dir { read open };

Comment 1 Daniel Walsh 2009-09-07 11:02:08 UTC
Fixed in selinux-policy-3.6.30-5.fc12.noarch

Comment 2 Daniel Walsh 2009-09-07 11:03:26 UTC
*** Bug 521563 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-07 11:03:43 UTC
*** Bug 521562 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2009-09-07 11:03:59 UTC
*** Bug 521561 has been marked as a duplicate of this bug. ***

Comment 5 Daniel Walsh 2009-09-07 11:07:02 UTC
*** Bug 521558 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.