Bug 521621 - repoclosure -n false positives related to noarch <-> arch switches
repoclosure -n false positives related to noarch <-> arch switches
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-07 06:07 EDT by Michael Schwendt
Modified: 2014-01-21 18:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 10:31:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-09-07 06:07:56 EDT
yum-3.2.24-1.fc11
yum-utils-1.1.23-1.fc11

$ uname -m
i686

Dunno whether this is new behaviour since these test-updates. Didn't check. All I know is that Yum 3.2.24 includes arch list related API changes.

Default "repoclosure -n" reports several false positives related to packages having switched from arch<->noarch.
Examples:

package: automaton-javadoc-1.11r1-2.fc11.i586 from fedora
  unresolved deps: 
     automaton = 0:1.11r1-2.fc11

$ yum list automaton-javadoc
Available Packages
automaton-javadoc.i586                    1.11r1-2.fc11                  fedora 
automaton-javadoc.noarch                  1.11r2-1.fc11                  updates

It checks the older i586 package while Yum would update to the newer noarch build.

package: emacs-sdcc-2.8.0-5.fc11.noarch from fedora
  unresolved deps: 
     sdcc = 0:2.8.0-5.fc11

$ yum list emacs-sdcc sdcc
Available Packages
emacs-sdcc.noarch                      2.8.0-5.fc11                      fedora 
emacs-sdcc.i586                        2.9.0-3.fc11                      updates
sdcc.i586                          2.9.0-3.fc11                          updates

Here it checks the older noarch package while Yum would updates to the newer i586 build of both emacs-sdcc and the required sdcc.

[...]

Those are issues I've worked around in extras-repoclosure when they first were considered permissible in Fedora Extras.
Comment 1 seth vidal 2009-10-12 14:59:43 EDT
I believe the latest repoclosure in yum-utils in F11 and rawhide has corrected this particular problem. Can you confirm on that and close if so?

Also, I asked this before, Michael, but if you want to talk about getting commit access for repoclosure/yum-utils let me know.
Comment 2 Bug Zapper 2010-04-28 06:12:42 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Tim Lauridsen 2010-05-05 08:50:51 EDT
Michael, can you validate that this is fixed in the current release of repoclosure ?
Comment 4 Michael Schwendt 2010-05-07 06:57:11 EDT
$ rpm -q yum-utils
yum-utils-1.1.26-1.fc12.noarch

reports

  package: automaton-javadoc-1.11r1-2.fc11.i586 from fedora-11-i386
    unresolved deps: 
       automaton = 0:1.11r1-2.fc11

which is still the same issue. The newer 'noarch' -javadoc subpkg is here:
https://admin.fedoraproject.org/updates/automaton-1.11r2-1.fc11
Comment 5 Bug Zapper 2010-06-28 10:31:00 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.