Bug 521717 - GVFS, Nautilus, Brasero, Rhythmbox cannot recognize burned audio CDs.
Summary: GVFS, Nautilus, Brasero, Rhythmbox cannot recognize burned audio CDs.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gvfs
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-07 22:44 UTC by Jud Craft
Modified: 2015-03-03 22:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-05 06:28:16 UTC
Type: ---


Attachments (Terms of Use)
log of devkit-disks --dump (19.91 KB, text/plain)
2009-09-08 23:32 UTC, Jud Craft
no flags Details
log of devkit-disks --dump for CD drive (1.66 KB, text/plain)
2009-09-08 23:35 UTC, Jud Craft
no flags Details
log of devkit-disks --dump after disc insertion (1.73 KB, text/plain)
2009-09-08 23:37 UTC, Jud Craft
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 591640 0 Normal RESOLVED Music CD burning with Main Program completes, but CD is unrecognized by Nautilus & Rhythmbox 2020-08-16 21:53:29 UTC
GNOME Bugzilla 594398 0 Normal RESOLVED GVFS cannot recognize certain audio CD media: drive disconnected 2020-08-16 21:53:30 UTC
Launchpad 395470 0 None None None Never

Description Jud Craft 2009-09-07 22:44:06 UTC
Description of problem:

Certain burned audio CDs cannot be recognized by the GNOME Desktop.  This includes Nautilus, Sound Juicer, and Rhythmbox.

For example, all of my friends use iTunes -- and I have tried and failed for the past two months to read, play, or rip any of these CDs successfully under Fedora.


Version-Release number of selected component (if applicable):
In particular, GVFS 1.2.3.


How reproducible:
Very, in the case of burned audio CDs (perhaps always).  Does not seem to affect data or mixed-mode CDs (most consumer music CDs).


Steps to Reproduce:
1.  Get a friend to make you a CD in iTunes.  (DAO/TAO, either works.)  Or, burn one in Brasero yourself (2.26.x or 2.26.x).
2.  Insert the CD into your Fedora system.
  

Actual results:
3.  No audio CD appears on your desktop.
4.  Your CD Drive device will disappear from Places/Computer.
5.  Rhythmbox does not detect a CD and cannot play it.


Expected results:
Nautilus and Rhythmbox, and the GNOME Desktop in general, should be able to detect and play any audio CD that Windows and Mac can play and create.


Additional info:
This may be due to the recent GVFS migration from HAL to udev.

Further information may be found at the following.

http://bugzilla.gnome.org/show_bug.cgi?id=591640  (brasero bug report - music CDs do not work.)

https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/395470  (ubuntu bug report)

http://bugzilla.gnome.org/show_bug.cgi?id=594398  (upstream GNOME bug report).

GNOME and Ubuntu reports contain information from gvfs-mount.


Ramifications:
The GNOME Desktop cannot read, play, or use in any other way many burned CDs, and in my case, most burned CDs I have from my friends (I have not found an exception).

Fedora (and it appears Ubuntu, too) is thus useless for dealing with burned audio media of any kind at this current time.

If this is due to the recent GVFS refactoring, I hope it will be patched soon, as this is a significant task pool that the GNOME Desktop currently cannot accomplish at all.  This is a big hole in the free desktop.


Also:

Banshee 1.4.x in Fedora can still read and rip CDs just fine, since its CD backend is still based on HAL.

Comment 1 Tomáš Bžatek 2009-09-08 09:32:26 UTC
This is interesting behaviour, most probably caused by the gdu volume monitor. You can try comparing output of `devkit-disks --dump` before and after Audio CD is inserted.

Any chance you can test gvfs 1.3 series (rawhide)? There's been numerous changes in drive handling.

Please report full version of your gvfs packages, we backported one Audio CD handling fix some time ago as part of bug 500341. That went to gvfs-1.2.3-7.f11

The Ubuntu bug may be different issue as they don't use gdu-based volume monitor yet.

Comment 2 Jud Craft 2009-09-08 11:59:44 UTC
GVFS 1.2.3-12.f11.

I'll update the package to rawhide and do the devkit-disks --dump trick later today.

It's possible the Ubuntu one is unrelated, but the symptoms are exactly the same as far as this user can tell.

Comment 3 Jud Craft 2009-09-08 23:31:14 UTC
Alright.  Updated to GVFS 1.3.5-2.f12, and libgudev 145.7.f12.

It didn't fix anything.  Inserting burned music CDs are still not recognized in Nautilus, Rhythmbox, or Sound Juicer.

Worse, it has significantly destabilized my system...not to be a whiner, but Nautilus now crashes consistently every time I open Places/Computer.

My log of devkit-disks --dump is attached, hope it's useful.  But aside from Nautilus instability, audio CDs are definitely not recognized.  In addition, gvfs-mount now gives the following errors in monitor mode.  Not sure if those mean anything to anyone.


-----
[judson@localhost ~]$ gvfs-mount -o

(gvfs-mount:2803): GVFS-RemoteVolumeMonitor-WARNING **: invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.Private.GduVolumeMonitor: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 127

(gvfs-mount:2803): GVFS-RemoteVolumeMonitor-WARNING **: invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.Private.HalVolumeMonitor: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
-----

Comment 4 Jud Craft 2009-09-08 23:32:38 UTC
Created attachment 360143 [details]
log of devkit-disks --dump

Comment 5 Jud Craft 2009-09-08 23:35:18 UTC
Created attachment 360146 [details]
log of devkit-disks --dump for CD drive

Removed hard drive information, sorry for the duplicate.

Comment 6 Jud Craft 2009-09-08 23:37:21 UTC
Created attachment 360147 [details]
log of devkit-disks --dump after disc insertion

Log reported after inserting a burned audio CD.

Comment 7 Tomáš Bžatek 2009-09-15 13:53:58 UTC
So, I still can't reproduce it here... tried to burn some Audio CDs using Brasero and k3b, both work fine. Do you use anything special in Brasero? Are you burning from WAV files or MP3s? Do you have CD-Text enabled? How long is the content (minutes)?

In nautilus-file-management-properties in the Media tab, do you have autorun enabled? Try changing the options there to see if your problem goes away.

Your devkit-disks outputs didn't show anything wrong, CD drive is still present. udevadm monitor shows only change events, no add/remove. Do you see any gvfsd-cdda processes in your desktop session?

Comment 8 Jud Craft 2009-09-15 15:46:45 UTC
In particular, I can point out something strange about my devkit-disks outputs:

"ejectable:  0"

GNOME cannot eject CDs (using Nautilus, since I obviously can't see the device to click "eject"), and often my CD drive is locked and I can't even mechanically eject the device.

You are saying that burnt audio CDs work fine in Nautilus and Rhythmbox?  And can Brasero eject your audio CDs successfully when done?

CD Audio merely says "Ask me what to do." in System/Prefs/File Management.

I'll check the gvfsd-cdda thing later today.

This is a major problem for me and occurs nearly every time, with many of my (non-mixed mode) commercial audio CDs.  The only peculiar thing I've done is update Brasero to rawhide.

If you really can't see any problem (and the Brasero author agrees that GVFS is causing problems, see GnomeBug 594415 [can't eject discs] and 590385 [can't detect blank disc media]), then I'll have to wait until I have time to try F12 Alpha to confirm that I alone haven't ruined my system.  But for audio CD tasks it is next to worthless now.

By the by, my friends always burn me CDs using CD-Text.  It bugs the garbage out of me that even back when everything worked, Sound Juicer/Banshee/anything-on-Fedora could *never* read CD Text.  But that's another problem.

Oh, I forgot to mention:  what versions of Brasero and GVFS are you using?

Comment 9 Bug Zapper 2009-11-16 12:02:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Bug Zapper 2010-11-04 10:10:44 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Bug Zapper 2010-12-05 06:28:16 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.