Bug 521771 - setroubleshoot: SELinux is preventing abrtd "read" access on executable.
Summary: setroubleshoot: SELinux is preventing abrtd "read" access on executable.
Keywords:
Status: CLOSED DUPLICATE of bug 521775
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:fd2212ad9d2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 09:40 UTC by Matěj Cepl
Modified: 2018-04-11 07:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 14:42:20 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-08 09:40:58 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing abrtd "read" access on executable.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                system_u:system_r:initrc_t:s0
Kontext cíle                 system_u:object_r:abrt_var_cache_t:s0
Objekty cíle                 executable [ file ]
Zdroj                         abrtd
Cesta zdroje                  /usr/sbin/abrtd (deleted)
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.30-2.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.204.rc9.fc12.x86_64 #1 SMP
                              Sat Sep 5 20:45:55 EDT 2009 x86_64 x86_64
Počet upozornění           1
Poprvé viděno               Po 7. září 2009, 18:13:16 CEST
Naposledy viděno             Po 7. září 2009, 18:13:16 CEST
Místní ID                   7df1a71a-c77b-4256-b2c1-0ab04f1203d8
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1252339996.373:441): avc:  denied  { read } for  pid=32286 comm="abrtd" name="executable" dev=dm-1 ino=195555 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252339996.373:441): arch=c000003e syscall=2 success=yes exit=10 a0=7f4fd8011d58 a1=0 a2=1b6 a3=238 items=0 ppid=1 pid=32286 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe=2F7573722F7362696E2F6162727464202864656C6574656429 subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:file read;

Comment 1 Daniel Walsh 2009-09-08 14:42:20 UTC

*** This bug has been marked as a duplicate of bug 521775 ***


Note You need to log in before you can comment on or make changes to this bug.