Bug 521775 - setroubleshoot: SELinux is preventing abrtd "add_name" access on abrt-db-journal.
Summary: setroubleshoot: SELinux is preventing abrtd "add_name" access on abrt-db...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:48294345b93...
: 521767 521768 521770 521771 521773 521774 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 09:43 UTC by Matěj Cepl
Modified: 2018-04-11 16:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 14:41:10 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-08 09:43:10 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing abrtd "add_name" access on abrt-db-journal.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                system_u:system_r:initrc_t:s0
Kontext cíle                 system_u:object_r:abrt_var_cache_t:s0
Objekty cíle                 abrt-db-journal [ dir ]
Zdroj                         abrtd
Cesta zdroje                  /usr/sbin/abrtd (deleted)
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.30-2.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.204.rc9.fc12.x86_64 #1 SMP
                              Sat Sep 5 20:45:55 EDT 2009 x86_64 x86_64
Počet upozornění           6
Poprvé viděno               Po 7. září 2009, 18:15:10 CEST
Naposledy viděno             Po 7. září 2009, 21:29:35 CEST
Místní ID                   cda0fe60-efee-47d4-b5c0-b63f03565e29
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1252351775.49:543): avc:  denied  { add_name } for  pid=1588 comm="abrtd" name="abrt-db-journal" scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252351775.49:543): avc:  denied  { create } for  pid=1588 comm="abrtd" name="abrt-db-journal" scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1252351775.49:543): avc:  denied  { read write open } for  pid=1588 comm="abrtd" name="abrt-db-journal" dev=dm-1 ino=2011 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252351775.49:543): arch=c000003e syscall=2 success=yes exit=12 a0=2160408 a1=42 a2=1a4 a3=8 items=0 ppid=1 pid=1588 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe=2F7573722F7362696E2F6162727464202864656C6574656429 subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:dir add_name;
allow initrc_t abrt_var_cache_t:file { read write create open };

Comment 1 Daniel Walsh 2009-09-08 14:41:10 UTC
Fixed in selinux-policy-3.6.30-5.fc12.noarch

Comment 2 Daniel Walsh 2009-09-08 14:41:44 UTC
*** Bug 521774 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-08 14:42:00 UTC
*** Bug 521773 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2009-09-08 14:42:20 UTC
*** Bug 521771 has been marked as a duplicate of this bug. ***

Comment 5 Daniel Walsh 2009-09-08 14:42:35 UTC
*** Bug 521770 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Walsh 2009-09-08 14:42:56 UTC
*** Bug 521768 has been marked as a duplicate of this bug. ***

Comment 7 Daniel Walsh 2009-09-08 14:43:10 UTC
*** Bug 521767 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.