Bug 521776 - setroubleshoot: SELinux is preventing gdb "read" access on /var/lib/rpm/Packages.
Summary: setroubleshoot: SELinux is preventing gdb "read" access on /var/lib/rpm/...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:5864c63e223...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 09:43 UTC by Matěj Cepl
Modified: 2018-04-11 11:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 14:40:48 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-08 09:43:49 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing gdb "read" access on /var/lib/rpm/Packages.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdb. It is not expected that this access is
required by gdb and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                system_u:system_r:initrc_t:s0
Kontext cíle                 system_u:object_r:rpm_var_lib_t:s0
Objekty cíle                 /var/lib/rpm/Packages [ file ]
Zdroj                         gdb
Cesta zdroje                  /usr/bin/gdb
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          gdb-6.8.50.20090818-8.fc12
RPM balíčky cíle           rpm-4.7.1-4.fc12
RPM politiky                  selinux-policy-3.6.30-2.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.204.rc9.fc12.x86_64 #1 SMP
                              Sat Sep 5 20:45:55 EDT 2009 x86_64 x86_64
Počet upozornění           6
Poprvé viděno               Po 7. září 2009, 17:43:00 CEST
Naposledy viděno             Po 7. září 2009, 21:30:59 CEST
Místní ID                   a5ed903c-7f86-4bdc-aa80-226b9c8469ae
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1252351859.901:549): avc:  denied  { read } for  pid=4145 comm="gdb" name="Packages" dev=dm-1 ino=24 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:rpm_var_lib_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1252351859.901:549): avc:  denied  { open } for  pid=4145 comm="gdb" name="Packages" dev=dm-1 ino=24 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:rpm_var_lib_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252351859.901:549): arch=c000003e syscall=2 success=yes exit=0 a0=4c3b1c0 a1=0 a2=0 a3=7fffb783bbb0 items=0 ppid=1588 pid=4145 auid=4294967295 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4294967295 comm="gdb" exe="/usr/bin/gdb" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t rpm_var_lib_t:file { read open };

Comment 1 Daniel Walsh 2009-09-08 14:40:48 UTC
Caused by abrt

Fixed in selinux-policy-3.6.30-5.fc12.noarch


Note You need to log in before you can comment on or make changes to this bug.