Bug 521814 - setroubleshoot: SELinux is preventing start (wine_t) "read" etc_t.
Summary: setroubleshoot: SELinux is preventing start (wine_t) "read" etc_t.
Keywords:
Status: CLOSED DUPLICATE of bug 521841
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:9dbeceba0f0...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 12:33 UTC by Antonio A. Olivares
Modified: 2009-09-10 17:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 14:28:06 UTC


Attachments (Terms of Use)

Description Antonio A. Olivares 2009-09-08 12:33:42 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing start (wine_t) "read" etc_t.

Detailed Description:

[start has a permissive type (wine_t). This access was not denied.]

SELinux denied access requested by start. It is not expected that this access is
required by start and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Additional Information:

Source Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Context                system_u:object_r:etc_t:s0
Target Objects                /etc/fonts/conf.d/20-fix-globaladvance.conf [
                              lnk_file ]
Source                        start
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           wine-core-1.1.26-1.fc12
Target RPM Packages           fontconfig-2.7.1-1.fc12
Policy RPM                    selinux-policy-3.6.28-5.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.162.rc6.git2.fc12.i686 #1 SMP Mon Aug 17
                              16:22:01 EDT 2009 i686 i686
Alert Count                   4
First Seen                    Thu 20 Aug 2009 07:35:30 AM CDT
Last Seen                     Mon 24 Aug 2009 12:01:05 PM CDT
Local ID                      fb00c170-a9db-4a77-a74e-adeed5d49a60
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1251133265.547:153): avc:  denied  { read } for  pid=4698 comm="start" name="20-fix-globaladvance.conf" dev=dm-0 ino=19504 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=lnk_file

node=(removed) type=SYSCALL msg=audit(1251133265.547:153): arch=40000003 syscall=33 success=yes exit=0 a0=7c963988 a1=4 a2=68809f48 a3=687f98b1 items=0 ppid=1609 pid=4698 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="start" exe="/usr/bin/wine-preloader" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t etc_t:lnk_file read;

Comment 1 Daniel Walsh 2009-09-08 14:28:06 UTC

*** This bug has been marked as a duplicate of bug 521841 ***


Note You need to log in before you can comment on or make changes to this bug.