Bug 521838 - setroubleshoot: SELinux is preventing libvirtd "write" access on /var/cache/libvirt.
Summary: setroubleshoot: SELinux is preventing libvirtd "write" access on /var/ca...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:8dd291de4ca...
: 521839 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 14:00 UTC by Matěj Cepl
Modified: 2018-04-11 07:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 14:20:31 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-08 14:00:29 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing libvirtd "write" access on /var/cache/libvirt.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by libvirtd. It is not expected that this access
is required by libvirtd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                unconfined_u:system_r:virtd_t:s0-s0:c0.c1023
Kontext cíle                 system_u:object_r:svirt_cache_t:s0
Objekty cíle                 /var/cache/libvirt [ dir ]
Zdroj                         libvirtd
Cesta zdroje                  /usr/sbin/libvirtd
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          libvirt-0.7.1-0.1.git3ef2e05.fc12
RPM balíčky cíle           libvirt-0.7.1-0.1.git3ef2e05.fc12
RPM politiky                  selinux-policy-3.6.30-4.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.204.rc9.fc12.x86_64 #1 SMP
                              Sat Sep 5 20:45:55 EDT 2009 x86_64 x86_64
Počet upozornění           3
Poprvé viděno               Út 8. září 2009, 15:59:39 CEST
Naposledy viděno             Út 8. září 2009, 15:59:39 CEST
Místní ID                   bf6fa447-9a01-4db2-84d6-9b0bfc3a0f9f
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1252418379.693:108): avc:  denied  { write } for  pid=11629 comm="libvirtd" name="libvirt" dev=dm-1 ino=75590 scontext=unconfined_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:svirt_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252418379.693:108): avc:  denied  { add_name } for  pid=11629 comm="libvirtd" name="qemu" scontext=unconfined_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:svirt_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252418379.693:108): avc:  denied  { create } for  pid=11629 comm="libvirtd" name="qemu" scontext=unconfined_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:svirt_cache_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252418379.693:108): arch=c000003e syscall=83 success=yes exit=0 a0=7d2ce0 a1=1ff a2=0 a3=7fffbc260690 items=0 ppid=1 pid=11629 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="libvirtd" exe="/usr/sbin/libvirtd" subj=unconfined_u:system_r:virtd_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= virtd_t ==============
allow virtd_t svirt_cache_t:dir { write create add_name };

Comment 1 Daniel Walsh 2009-09-08 14:20:31 UTC
Fixed in selinux-policy-3.6.30-5.fc12.noarch

Comment 2 Daniel Walsh 2009-09-08 14:24:38 UTC
*** Bug 521839 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.