Bug 521845 - setroubleshoot: SELinux is preventing the winemenubuilder from using potentially mislabeled files (/home/olivares/.local/share/mime/globs).
Summary: setroubleshoot: SELinux is preventing the winemenubuilder from using pot...
Keywords:
Status: CLOSED DUPLICATE of bug 521841
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:3dab811cb29...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 14:10 UTC by Antonio A. Olivares
Modified: 2009-09-08 14:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 14:26:35 UTC


Attachments (Terms of Use)

Description Antonio A. Olivares 2009-09-08 14:10:15 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the winemenubuilder from using potentially mislabeled
files (/home/olivares/.local/share/mime/globs).

Detailed Description:

[winemenubuilder has a permissive type (wine_t). This access was not denied.]

SELinux has denied winemenubuilder access to potentially mislabeled file(s)
(/home/olivares/.local/share/mime/globs). This means that SELinux will not allow
winemenubuilder to use these files. It is common for users to edit files in
their home directory or tmp directories and then move (mv) them to system
directories. The problem is that the files end up with the wrong file context
which confined applications are not allowed to access.

Allowing Access:

If you want winemenubuilder to access this files, you need to relabel them using
restorecon -v '/home/olivares/.local/share/mime/globs'. You might want to
relabel the entire directory using restorecon -R -v
'/home/olivares/.local/share/mime'.

Additional Information:

Source Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:gconf_home_t:s0
Target Objects                /home/olivares/.local/share/mime/globs [ file ]
Source                        winemenubuilder
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           wine-core-1.1.26-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.28-5.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.162.rc6.git2.fc12.i686 #1 SMP Mon Aug 17
                              16:22:01 EDT 2009 i686 i686
Alert Count                   1
First Seen                    Mon 24 Aug 2009 12:01:09 PM CDT
Last Seen                     Mon 24 Aug 2009 12:01:09 PM CDT
Local ID                      b9652015-5c7d-4789-bb44-5ac63c16c671
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1251133269.737:167): avc:  denied  { getattr } for  pid=4710 comm="winemenubuilder" path="/home/olivares/.local/share/mime/globs" dev=dm-0 ino=125907 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:gconf_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1251133269.737:167): arch=40000003 syscall=197 success=yes exit=0 a0=a a1=33f6f8 a2=682d6ff4 a3=7d5670c0 items=0 ppid=1 pid=4710 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="winemenubuilder" exe="/usr/bin/wine-preloader" subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= wine_t ==============
allow wine_t gconf_home_t:file getattr;

Comment 1 Daniel Walsh 2009-09-08 14:26:35 UTC

*** This bug has been marked as a duplicate of bug 521841 ***


Note You need to log in before you can comment on or make changes to this bug.