Bug 521893 - clang broken on x86_64
clang broken on x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-08 11:56 EDT by Dan Winship
Modified: 2009-09-10 00:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 00:42:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2009-09-08 11:56:23 EDT
clang looks for its includes in /usr/lib/clang/1.0/include/, but they're installed into /usr/lib64/clang/1.0/include on x86_64. 

llvm-clang-2.6-0.3.pre1.fc12.x86_64
Comment 1 Michel Alexandre Salim 2009-09-09 03:21:06 EDT
It turns out the headers are identical, so I'm patching Makefile.rules to use -p when installing data files, and reverting the sed invocation I used to install to %{_lib}.

I'm asking upstream what their package naming preference is (llvm-clang is a bit long, llvm-clang-analyzer even longer), so I'm holding back on releasing the fix for now. 2.6.0 pre2 will be out soon too. In the meantime, could you just symlink /usr/lib64/clang to /usr/lib/clang and check if everything else works?

Thanks!
Comment 2 Dan Winship 2009-09-09 08:23:02 EDT
yeah, i was just doing "CPPFLAGS=-I/usr/lib64/clang/1.0/include" before, and that was working fine
Comment 3 Michel Alexandre Salim 2009-09-10 00:42:47 EDT
This should be fixed in 0.5.pre1 (0.4.pre1 failed to build on ppc because of GCC's new var-tracking-assignments).

clang can now be installed without pulling in LLVM -- it can generate native code, native assembly, LLVM IR assembly and LLVM bitcode by itself. I'm not polluting the spec file with Provides: and Obsoletes: since there's been only one clang release before that, so please uninstall llvm-clang first.

Note You need to log in before you can comment on or make changes to this bug.