Bug 521910 - setroubleshoot: SELinux is preventing abrtd "remove_name" access on kerneloops-1252428104-2.lock.
Summary: setroubleshoot: SELinux is preventing abrtd "remove_name" access on kern...
Keywords:
Status: CLOSED DUPLICATE of bug 521906
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:2e4342e3e77...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 16:49 UTC by Moisés Ramos
Modified: 2009-09-08 23:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-08 23:23:12 UTC


Attachments (Terms of Use)

Description Moisés Ramos 2009-09-08 16:49:08 UTC
The following was filed automatically by setroubleshoot:

Resúmen:

SELinux is preventing abrtd "remove_name" access on
kerneloops-1252428104-2.lock.

Descripción Detallada:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Permitiendo Acceso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Información Adicional:

Contexto Fuente               system_u:system_r:initrc_t:s0
Contexto Destino              system_u:object_r:var_t:s0
Objetos Destino               kerneloops-1252428104-2.lock [ dir ]
Fuente                        abrtd
Dirección de Fuente          /usr/sbin/abrtd
Puerto                        <Desconocido>
Nombre de Equipo              (removed)
Paquetes RPM Fuentes          abrt-0.0.8.5-1.fc12
Paquetes RPM Destinos         
RPM de Políticas             selinux-policy-3.6.30-4.fc12
SELinux Activado              True
Tipo de Política             targeted
MLS Activado                  True
Modo Obediente                Enforcing
Nombre de Plugin              catchall
Nombre de Equipo              (removed)
Plataforma                    Linux (removed) 2.6.31-0.204.rc9.fc12.x86_64 #1
                              SMP Sat Sep 5 20:45:55 EDT 2009 x86_64 x86_64
Cantidad de Alertas           2
Visto por Primera Vez         mar 08 sep 2009 18:41:44 CEST
Visto por Última Vez         mar 08 sep 2009 18:41:44 CEST
ID Local                      a5b713c9-5cef-4f99-8b02-154927037867
Números de Línea            

Mensajes de Auditoría Crudos 

node=(removed) type=AVC msg=audit(1252428104.94:47): avc:  denied  { remove_name } for  pid=1350 comm="abrtd" name="kerneloops-1252428104-2.lock" dev=sda1 ino=13948 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252428104.94:47): avc:  denied  { unlink } for  pid=1350 comm="abrtd" name="kerneloops-1252428104-2.lock" dev=sda1 ino=13948 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252428104.94:47): arch=c000003e syscall=87 success=yes exit=0 a0=15ae2c8 a1=0 a2=0 a3=7fffdac05a90 items=0 ppid=1 pid=1350 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t var_t:dir remove_name;
allow initrc_t var_t:file unlink;

Comment 1 Daniel Walsh 2009-09-08 23:23:12 UTC

*** This bug has been marked as a duplicate of bug 521906 ***


Note You need to log in before you can comment on or make changes to this bug.