Bug 521965 - kdebase-workspace-googlegadgets incorrect display gadgets
Summary: kdebase-workspace-googlegadgets incorrect display gadgets
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 21:26 UTC by Cepreu
Modified: 2009-09-22 22:43 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-22 20:53:34 UTC


Attachments (Terms of Use)
Screenshot of this problem. (1.57 MB, image/png)
2009-09-08 21:26 UTC, Cepreu
no flags Details
Screenshot of ggl-qt look. (1.49 MB, image/png)
2009-09-10 10:20 UTC, Cepreu
no flags Details


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 207645 None None None Never

Description Cepreu 2009-09-08 21:26:11 UTC
Created attachment 360136 [details]
Screenshot of this problem.

Description of problem:
When i add google gadget to desktop is displaying with cutting right and bottom edges.

Version-Release number of selected component (if applicable):
google-gadgets-qt-0.11.0-4.fc11.i586
google-gadgets-0.11.0-4.fc11.i586
kdebase-workspace-googlegadgets-4.3.0-9.fc11.i586

Steps to Reproduce:
1. Right click on desktop.
2. Add widgets.
3. "Install new widgets" button add bottom of window appeared.
4. Select "Download new google gadgets" from combo box.
5. Click "Add" button on widget "Analog Clock".
6. Close gadget browser.
7. Add new downloaded gadget to desktop.
  
Actual results:
Look at screenshot.

Expected results:
Must be look normally.

Additional info:
1. It is not only in this gadget. All gadgets works incorrect.
2. If you resize gadgets to very large scale, they looks right, but it is no beauty at all.

Comment 1 Michel Alexandre Salim 2009-09-10 08:18:52 UTC
Can you reproduce this if you run ggl-qt directly? If you can, then it is a google-gadgets bug; if not, then it is a kdebase-workspace bug

Comment 2 Cepreu 2009-09-10 10:16:42 UTC
I use ggl-qt now, while kdebase-workspace-googlegadgets still not fixed for this bug. In ggl-qt all looks normally, but exist problem: when use "Show desktop feature", gadgets also hides. But this bug never will be fixed (as i can see in bugzilla of project), so i want to use kdebase-workspace-googlegadgets.
And look at screenshot. Which i attach now. It is ggl-qt and it is looks fine. So, yes it is bug in kdebase-workspace. I just does not found kdebase-workspace-googlegadgets in packages list on bugzilla. So i can not report about it to kde packagers, as i was thinked. Can you assign this bug to right project, please?

Comment 3 Cepreu 2009-09-10 10:20:46 UTC
Created attachment 360478 [details]
Screenshot of ggl-qt look.

Comment 4 Michel Alexandre Salim 2009-09-12 16:53:47 UTC
The component to file the bug against is the one in the "Source RPM" field when you do rpm -qi -- so in this case, kdebase-workspace.

Comment 5 Steven M. Parrish 2009-09-13 01:53:44 UTC
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Rex Dieter 2009-09-22 20:53:34 UTC
Will continue tracking issue upstream.

Comment 8 Rex Dieter 2009-09-22 20:55:55 UTC
hrm, just added analog clock, unfortunately, I'm unable to reproduce the problem myself, no matter how I orient or resize it.

$ rpm -q google-gadgets-qt kdebase-workspace-googlegadgets
google-gadgets-qt-0.11.1-1.fc11.x86_64
kdebase-workspace-googlegadgets-4.3.1-1.fc11.x86_64

Comment 9 Rex Dieter 2009-09-22 20:58:03 UTC
Can you still reproduce this with kde-4.3.1 (now in stable updates) ?

Comment 10 Cepreu 2009-09-22 22:43:04 UTC
Yes, bug still exist.


Note You need to log in before you can comment on or make changes to this bug.