Bug 522029 - grub : Error 18: Selected cylinder exceeds maximum supported by BIOS
Summary: grub : Error 18: Selected cylinder exceeds maximum supported by BIOS
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: grub
Version: 5.4
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Václav Pavlín
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 08:25 UTC by Winfrid Tschiedel
Modified: 2013-03-19 13:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-19 13:08:59 UTC


Attachments (Terms of Use)

Description Winfrid Tschiedel 2009-09-09 08:25:07 UTC
Description of problem:
grub cannot write BOOTRECORD into the partion -
ends with Error 18: Selected cylinder exceeds maximum supported by BIOS


Version-Release number of selected component (if applicable):
grub-0.97-13.5

How reproducible:
always - independant of the redhat linux distribution 
seen also with fedora 12, rhel-6
but not with NOVELL linux distributions


Steps to Reproduce:
1. write on a system (with dmraid?) in the extended partition a bootrecord
   to a partition
2.
3.
  
Actual results:
Error 18: Selected cylinder exceeds maximum supported by BIOS

Expected results:
grub writes bootrecord to the partion


Additional info:

I have a similar system, where I have no problems to write a bootrecord
to a partition ( partition nimber >= 5 )

grub on the system in trouble :
[root@rx220a ~]# uname -a
Linux rx220a 2.6.18-128.1.14.el5 #1 SMP Mon Jun 1 15:52:58 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[root@rx220a ~]# rpm -qa | grep grub
[root@rx220a ~]# grub 
Probing devices to guess BIOS drives. This may take a long time.


    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]
grub> device (hd0,1) /dev/mapper/pdc_bjfeeibeebp1
device (hd0,1) /dev/mapper/pdc_bjfeeibeebp1
grub> device (hd0) /dev/mapper/pdc_bjfeeibeeb
device (hd0) /dev/mapper/pdc_bjfeeibeeb
grub> root (hd0,1)
root (hd0,1)
 Filesystem type is ext2fs, partition type 0x83
grub> device (hd0,10)  /dev/mapper/pdc_bjfeeibeebp11
device (hd0,10)  /dev/mapper/pdc_bjfeeibeebp11 
grub> root (hd0,10)
root (hd0,10)

Error 18: Selected cylinder exceeds maximum supported by BIOS

Result from a similar system :
[root@rx220b ~]# uname -a
Linux rx220b 2.6.27.30-170.2.82.fc10.x86_64 #1 SMP Mon Aug 17 08:18:34 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[root@rx220b ~]# rpm -qa | grep grub
grub-0.97-38.fc10.x86_64
[root@rx220b ~]# grub 
Probing devices to guess BIOS drives. This may take a long time.


    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]
grub> device (hd0,6) /dev/mapper/pdc_cjgdhdfafhp7
device (hd0,6) /dev/mapper/pdc_cjgdhdfafhp7
grub> device (hd0) /dev/mapper/pdc_cjgdhdfafh
device (hd0) /dev/mapper/pdc_cjgdhdfafh
grub> root (hd0,6)
root (hd0,6)
 Filesystem type is ext2fs, partition type 0x83
grub> quit

So I checked the partitiontable :
on rhel-5 :
[root@rx220a ~]# sfdisk /dev/mapper/pdc_bjfeeibeeb
Checking that no-one is using this disk right now ...
BLKRRPART: Invalid argument
OK

Disk /dev/mapper/pdc_bjfeeibeeb: 19444 cylinders, 255 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Old situation:
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/mapper/pdc_bjfeeibeeb1   *      0+     12-     13-    104390+  83  Linux
/dev/mapper/pdc_bjfeeibeeb2         12+   2101-   2089-  16779892   83  Linux
/dev/mapper/pdc_bjfeeibeeb3       2101+   2623-    522    4192965   82  Linux swap / Solaris
/dev/mapper/pdc_bjfeeibeeb4       2623+  19443   16821- 135106682    5  Extended
/dev/mapper/pdc_bjfeeibeeb5       2623+   4712-   2089-  16779860+  83  Linux
/dev/mapper/pdc_bjfeeibeeb6       4712+   6795-   2083-  16731665+  83  Linux
/dev/mapper/pdc_bjfeeibeeb7       6796+   8886    2091-  16795926   83  Linux
/dev/mapper/pdc_bjfeeibeeb8       8887+  11062    2176-  17478688+  83  Linux
/dev/mapper/pdc_bjfeeibeeb9      11063+  13673    2611-  20972826   83  Linux
/dev/mapper/pdc_bjfeeibeeb10     13674+  16047    2374-  19069123+  83  Linux
/dev/mapper/pdc_bjfeeibeeb11     16048+  17704    1657-  13309821   83  Linux
Input in the following format; absent fields get a default value.
<start> <size> <type [E,S,L,X,hex]> <bootable [-,*]> <c,h,s> <c,h,s>
Usually you only need to specify <start> and <size> (and perhaps <type>).

fedora 10:
[root@rx220b ~]# sfdisk /dev/mapper/pdc_cjgdhdfafh
Checking that no-one is using this disk right now ...
BLKRRPART: Invalid argument
OK

Disk /dev/mapper/pdc_cjgdhdfafh: 9717 cylinders, 255 heads, 63 sectors/track
Old situation:
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/mapper/pdc_cjgdhdfafh1   *      0+     12      13-    104391   83  Linux
/dev/mapper/pdc_cjgdhdfafh2         13    1579    1567   12586927+  83  Linux
/dev/mapper/pdc_cjgdhdfafh3       1580    2101     522    4192965   82  Linux swap / Solaris
/dev/mapper/pdc_cjgdhdfafh4       2102    9716    7615   61167487+   5  Extended
/dev/mapper/pdc_cjgdhdfafh5       2102+   3668    1567-  12586896   83  Linux
/dev/mapper/pdc_cjgdhdfafh6       3669+   6087    2419-  19430586   83  Linux
/dev/mapper/pdc_cjgdhdfafh7       6088+   7654    1567-  12586896   83  Linux
/dev/mapper/pdc_cjgdhdfafh8       7655+   9716    2062-  16562983+  83  Linux
Input in the following format; absent fields get a default value.
<start> <size> <type [E,S,L,X,hex]> <bootable [-,*]> <c,h,s> <c,h,s>
Usually you only need to specify <start> and <size> (and perhaps <type>).

So I suppose that the problem on rhel-5 is caused by 
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.

Comment 1 Václav Pavlín 2013-03-18 14:31:33 UTC
Hi, the error message is addressing exceeding of BIOS limitations. Some information can be found here http://members.iinet.net/~herman546/p15.html#18

From my point of view this is not something which can be fixed in grub - closing.

Comment 2 Winfrid Tschiedel 2013-03-19 12:44:08 UTC
(In reply to comment #1)
> Hi, the error message is addressing exceeding of BIOS limitations. Some
> information can be found here http://members.iinet.net/~herman546/p15.html#18
> 
> From my point of view this is not something which can be fixed in grub -
> closing.

Hi Václav,

This is a new record from RedHat -
it looks like that nobody touched this incident for more than 3 years -
and then your conclusion is, that this can't be fixed.

Just a question to you, why do you think that it worked with
openSUSE or SLES ?????

Winfrid

Comment 3 Václav Pavlín 2013-03-19 13:08:59 UTC
Hi, so what I see from output of sfdisk, you have disks configured completely different. That leads me to my conclusion that there might the problem - not in grub.

Anyway, RHEL-5 is in very late phase of release cycle and even if I would consider this a grub bug, I would not think it is critical enough to be fixed now.

Vaclav


Note You need to log in before you can comment on or make changes to this bug.