Bug 522076 - root partition not found after kernelupdate (SATA RAID)
Summary: root partition not found after kernelupdate (SATA RAID)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 12:27 UTC by Winfrid Tschiedel
Modified: 2009-09-16 08:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 05:58:26 UTC


Attachments (Terms of Use)
list of initrd (successful execution) (161.55 KB, text/plain)
2009-09-09 12:27 UTC, Winfrid Tschiedel
no flags Details
lsinitrd for kernel-2.6.31-204.rc9.fc12 (153.17 KB, text/plain)
2009-09-09 12:30 UTC, Winfrid Tschiedel
no flags Details
changed grub.conf - works with kernel-2.6.31-0.204.rc9.fc12.x86_64 (1.63 KB, text/plain)
2009-09-10 14:37 UTC, Winfrid Tschiedel
no flags Details

Description Winfrid Tschiedel 2009-09-09 12:27:35 UTC
Created attachment 360202 [details]
list of initrd (successful execution)

Description of problem:
After update to kernel-2.6.31-0.204.rc9.fc12 I get the message 
rootpartition not found

Version-Release number of selected component (if applicable):
2.6.31-0.204.rc9

How reproducible:
always on system with SATA RAID (dmraid)


Steps to Reproduce:
1. Have fedora 11.91 with root partition on SATA RAID (dmraid)
2. Update to the newest kernel kernel-2.6.31-0.204.rc9.fc12 
3. reboot the system 
  
Actual results:
System cannot access rootpartition

Expected results:
successful boot

Additional info:
No problems with previous kernels, last tested kernel : 2.6.31-0.190.rc8.fc12
No problems with SASRAID (LSI)

Comment 1 Winfrid Tschiedel 2009-09-09 12:30:33 UTC
Created attachment 360203 [details]
lsinitrd for kernel-2.6.31-204.rc9.fc12

Comment 2 Hans de Goede 2009-09-10 08:48:16 UTC
Hi Winfrid,

What kind of BIOS RAID is this, promise / intel / ??
Also what sort of setup (how many sets, type of raid per set, number of disks per set ?)

Can you please run:
blkid -o udev -p /dev/sda
blkid -o udev -p /dev/sdb

etc.

And also "dmraid -ay -t"

And paste the output of all of the above here ?

Thx,

Hans

Comment 3 Hans de Goede 2009-09-10 08:51:24 UTC
Note: this is probably caused by dracut, changing component.

Comment 4 Harald Hoyer 2009-09-10 09:29:14 UTC
please update dracut to version >= 001-7 and rebuild your initrd:

# yum update dracut
# dracut -f /boot/initrd-generic-2.6.31-204.rc9.fc12.x86_64.img \
   2.6.31-204.rc9.fc12.x86_64

Comment 5 Winfrid Tschiedel 2009-09-10 10:58:29 UTC
Hi Harald,

I just checked 
ftp://ftp.tu-chemnitz.de/pub/linux/fedora/linux/development/x86_64/os/Packages

and 
[BINARY]     dracut-001-4.fc12.noarch.rpm . . . . . .    [Sep 07 17:26]     55K
[BINARY]     dracut-generic-001-4.fc12.noarch.rpm . .    [Sep 07 17:26]      4K
[BINARY]     dracut-kernel-001-4.fc12.noarch.rpm. . .    [Sep 07 17:26]      4K
[BINARY]     dracut-modules-olpc-0.2.1-2.fc12.x86_64.rpm    [Aug 12 14:27]     79K
[BINARY]     dracut-network-001-4.fc12.noarch.rpm . .    [Sep 07 17:26]     21K
[BINARY]     dracut-tools-001-4.fc12.noarch.rpm . . .    [Sep 07 17:26]     18K

What should/can I do now ?

Winfrid

Comment 6 Hans de Goede 2009-09-10 11:01:08 UTC
Winfrid, you can download the latest dracut here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=131294

Comment 7 Harald Hoyer 2009-09-10 11:02:31 UTC
if you do not have an olpc, you should remove 
dracut-modules-olpc-0.2.1-2.fc12.x86_64.rpm
by the way

Comment 8 Winfrid Tschiedel 2009-09-10 13:36:04 UTC
Hi Harald,

Until now no dracut was installed -

[root@rx220a ~]# dracut -f /boot/initrd-generic-2.6.31-204.rc9.fc12.x86_64.img  2.6.31-204.rc9.fc12.x86_64 
find: `/lib/modules/2.6.31-204.rc9.fc12.x86_64//kernel/drivers/gpu/drm': No such file or directory
find: `/lib/modules/2.6.31-204.rc9.fc12.x86_64//kernel/drivers': No such file or directory
find: `/lib/modules/2.6.31-204.rc9.fc12.x86_64/': No such file or directory
find: `/lib/modules/2.6.31-204.rc9.fc12.x86_64/': No such file or directory

23765 blocks

Let's see what happens - Winfrid

Comment 9 Winfrid Tschiedel 2009-09-10 13:39:49 UTC
No change :

No root device found

Boot has failed, sleeping forever

.......

Comment 10 Winfrid Tschiedel 2009-09-10 13:44:28 UTC
(In reply to comment #2)
> Hi Winfrid,
> What kind of BIOS RAID is this, promise / intel / ??
> Also what sort of setup (how many sets, type of raid per set, number of disks
> per set ?)
> Can you please run:
> blkid -o udev -p /dev/sda
> blkid -o udev -p /dev/sdb
> etc.
> And also "dmraid -ay -t"
> And paste the output of all of the above here ?
> Thx,
> Hans  

Hans,

It is promise and just 1 disk in 1 linear raid -
I cannot the commands with new kernel so I will do it for the working kernel.

Comment 11 Winfrid Tschiedel 2009-09-10 13:53:34 UTC
[root@rx220a ~]# blkid -o udev -p /dev/sda
ID_FS_TYPE=promise_fasttrack_raid_member
ID_FS_USAGE=raid
[root@rx220a ~]# dmraid -ay -t
pdc_bjfeeibeeb: 0 312368896 linear /dev/sda 0
pdc_bjfeeibeebp1: 0 208781 linear /dev/mapper/pdc_bjfeeibeeb 1
pdc_bjfeeibeebp2: 0 33559784 linear /dev/mapper/pdc_bjfeeibeeb 208782
pdc_bjfeeibeebp3: 0 8385930 linear /dev/mapper/pdc_bjfeeibeeb 33768566
pdc_bjfeeibeebp5: 0 33559721 linear /dev/mapper/pdc_bjfeeibeeb 42154497
pdc_bjfeeibeebp6: 0 33463331 linear /dev/mapper/pdc_bjfeeibeeb 75714219
pdc_bjfeeibeebp7: 0 33591852 linear /dev/mapper/pdc_bjfeeibeeb 109177803
pdc_bjfeeibeebp8: 0 34957377 linear /dev/mapper/pdc_bjfeeibeeb 142769718
pdc_bjfeeibeebp9: 0 41945652 linear /dev/mapper/pdc_bjfeeibeeb 177727158
pdc_bjfeeibeebp10: 0 38138247 linear /dev/mapper/pdc_bjfeeibeeb 219672873
pdc_bjfeeibeebp11: 0 26619642 linear /dev/mapper/pdc_bjfeeibeeb 257811183

Comment 12 Hans de Goede 2009-09-10 14:05:29 UTC
(In reply to comment #11)
> [root@rx220a ~]# blkid -o udev -p /dev/sda
> ID_FS_TYPE=promise_fasttrack_raid_member
> ID_FS_USAGE=raid
> [root@rx220a ~]# dmraid -ay -t
> pdc_bjfeeibeeb: 0 312368896 linear /dev/sda 0
> pdc_bjfeeibeebp1: 0 208781 linear /dev/mapper/pdc_bjfeeibeeb 1
> pdc_bjfeeibeebp2: 0 33559784 linear /dev/mapper/pdc_bjfeeibeeb 208782
> pdc_bjfeeibeebp3: 0 8385930 linear /dev/mapper/pdc_bjfeeibeeb 33768566
> pdc_bjfeeibeebp5: 0 33559721 linear /dev/mapper/pdc_bjfeeibeeb 42154497
> pdc_bjfeeibeebp6: 0 33463331 linear /dev/mapper/pdc_bjfeeibeeb 75714219
> pdc_bjfeeibeebp7: 0 33591852 linear /dev/mapper/pdc_bjfeeibeeb 109177803
> pdc_bjfeeibeebp8: 0 34957377 linear /dev/mapper/pdc_bjfeeibeeb 142769718
> pdc_bjfeeibeebp9: 0 41945652 linear /dev/mapper/pdc_bjfeeibeeb 177727158
> pdc_bjfeeibeebp10: 0 38138247 linear /dev/mapper/pdc_bjfeeibeeb 219672873
> pdc_bjfeeibeebp11: 0 26619642 linear /dev/mapper/pdc_bjfeeibeeb 257811183  

Hmm, were these commands executed on the same installation as were you installed the new dracut and regenerated the initrd ?

What does "rpm -q dmraid" say ?

Comment 13 Winfrid Tschiedel 2009-09-10 14:34:26 UTC
Hi Hans,

It is the same system, just kernel-2.6.31-0.190.rc8.fc12.x86_64

[root@rx220a ~]# uname -a
Linux rx220a.mch.fts.net 2.6.31-0.190.rc8.fc12.x86_64 #1 SMP Fri Aug 28 18:51:58 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[root@rx220a ~]# rpm -q kernel
kernel-2.6.31-0.125.4.2.rc5.git2.fc12.x86_64
kernel-2.6.31-0.190.rc8.fc12.x86_64
kernel-2.6.31-0.204.rc9.fc12.x86_64
[root@rx220a ~]# rpm -q dmraid
dmraid-1.0.0.rc15-8.fc12.x86_64

I found now the reason why the system did not boot the kernel -
I changed the root-device from root=UUID=.... to
root=/dev/mapper/pdc_bjfeeibeebp9

and now my system is up :
[root@rx220a ~]# uname -a 
Linux rx220a.mch.fts.net 2.6.31-0.204.rc9.fc12.x86_64 #1 SMP Sat Sep 5 20:45:55 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[root@rx220a ~]# df -kT
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/mapper/pdc_bjfeeibeebp9
              ext3    20641788   4662540  14930608  24% /
tmpfs        tmpfs     1773620         0   1773620   0% /dev/shm

so you have just to find out why root=UUID=5dd76abf-08fa-4215-a209-3ffb995c5f09
does not work, I will attach the updated grub.conf

Comment 14 Winfrid Tschiedel 2009-09-10 14:37:33 UTC
Created attachment 360511 [details]
changed grub.conf - works with kernel-2.6.31-0.204.rc9.fc12.x86_64

Comment 15 Hans de Goede 2009-09-10 14:45:14 UTC
Hmm, root=UUID=.... not working is a known (and fixed) issue. Are you sure you have installed the latest dracut, what does:
rpm -q dracut say ?

And are you sure you've successfully regenerated the initrd:

dracut -f /boot/initrd-generic-2.6.31-0.204.rc9.fc12.x86_64.img \
  2.6.31-0.204.rc9.fc12.x86_64

?

Comment 16 Harald Hoyer 2009-09-10 14:51:08 UTC
you can check it with 

# lsinitrd /boot/initrd-generic-2.6.31-0.204.rc9.fc12.x86_64.img | grep dracut-

Comment 17 Winfrid Tschiedel 2009-09-10 14:57:21 UTC
[root@rx220a ~]# lsinitrd /boot/initrd-generic-2.6.31-0.204.rc9.fc12.x86_64.img | grep dracut-
-rw-r--r--   1 root     root         2460 Sep  2 15:54 lib/dracut-lib.sh
-rw-r--r--   1 root     root           18 Sep  6 02:59 dracut-001-2.fc12
. /lib/dracut-lib.sh
init

And I had until today no dracut on my system.

Winfrid

Comment 18 Harald Hoyer 2009-09-10 15:06:15 UTC
so, do like comment #15 says.. add the UUID back in grub.conf and try to reboot.

Comment 19 Hans de Goede 2009-09-10 15:14:31 UTC
(In reply to comment #18)
> so, do like comment #15 says.. add the UUID back in grub.conf and try to
> reboot.  

To be clear what Harald is trying to say is:
1) ensure you've got dracut-001-7 or newer
2) do:
dracut -f /boot/initrd-generic-2.6.31-0.204.rc9.fc12.x86_64.img \
  2.6.31-0.204.rc9.fc12.x86_64
3) add the UUID back in grub.conf
4) reboot

Comment 20 Winfrid Tschiedel 2009-09-11 13:14:37 UTC
Sorry,

I should not do too many things in parallel - in the meantime I fixed the dracut problem and I am using the correct version of dracut but still the same:

[root@rx220a ~]# lsinitrd /boot/initrd-generic-2.6.31-0.204.rc9.fc12.x86_64.img  | grep dracut-
-rw-r--r--   1 root     root           30 Sep 10 17:34 dracut-001-9.git6f0e469d.fc12
-rw-r--r--   1 root     root         2540 Sep  9 19:50 lib/dracut-lib.sh
init
. /lib/dracut-lib.sh

After this I recreated initrd with mkinitrd 
[root@rx220a ~]# mkinitrd -f /boot/initrd-generic-2.6.31-0.204.rc9.fc12.x86_64.img 2.6.31-0.204.rc9.fc12.x86_64
get_netlink_msg returned No such file or directory
get_netlink_msg returned No such file or directory
[root@rx220a ~]# lsinitrd /boot/initrd-generic-2.6.31-0.204.rc9.fc12.x86_64.img | grep UUID
init
resume UUID=7cd5484a-618b-45cc-b0da-4cb148366953
mkrootdev -t ext3 -o defaults,ro UUID=5dd76abf-08fa-4215-a209-3ffb995c5f09

After using mkinitrd instead of dracut my system is up -
which leads to 2 questions :

my mass update including update of the kernel did not include 
any dracut - I had to install dracut manually 
and even using the latest dracut does not solve the problem

TGiF,

Winfrid

Comment 21 Harald Hoyer 2009-09-11 13:22:46 UTC
so you booted the dracut image with root=UUID=5dd76abf-08fa-4215-a209-3ffb995c5f09
 and that did not work?

Comment 22 Winfrid Tschiedel 2009-09-11 13:48:45 UTC
Just to be more precise then in #20 :
Even the initrd with the newest drucut does not work -
but there was no problem with the one created by mkinitrd !

Comment 23 Harald Hoyer 2009-09-11 14:03:21 UTC
What is the output of:

# blkid -o udev -p /dev/mapper/pdc_bjfeeibeebp9

Comment 24 Harald Hoyer 2009-09-11 14:23:30 UTC
oh, and:

# rpm -qf /usr/share/dracut/modules.d/* | sort -u

Comment 25 Winfrid Tschiedel 2009-09-11 14:38:09 UTC
[root@rx220a ~]# blkid -o udev -p /dev/mapper/pdc_bjfeeibeebp9  
ID_FS_UUID=5dd76abf-08fa-4215-a209-3ffb995c5f09
ID_FS_UUID_ENC=5dd76abf-08fa-4215-a209-3ffb995c5f09
ID_FS_VERSION=1.0
ID_FS_TYPE=ext3
ID_FS_USAGE=filesystem

[root@rx220a tmp]# rpm -qf /usr/share/dracut/modules.d/* | sort -u
dracut-001-9.git6f0e469d.fc12.noarch

Comment 26 Hans de Goede 2009-09-11 14:49:00 UTC
Winfrid are you using a GPT partition table on that machine?

Comment 27 Winfrid Tschiedel 2009-09-11 15:14:55 UTC
Not this time :

[root@rx220a ~]# parted /dev/mapper/pdc_bjfeeibeeb
GNU Parted 1.9.0
Using /dev/mapper/pdc_bjfeeibeeb
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p                                                                
Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/pdc_bjfeeibeeb: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      512B    107MB   107MB   primary   ext3            boot
 2      107MB   17.3GB  17.2GB  primary   ext3
 3      17.3GB  21.6GB  4294MB  primary   linux-swap(v1)  swap
 4      21.6GB  160GB   138GB   extended
 5      21.6GB  38.8GB  17.2GB  logical   ext3
 6      38.8GB  55.9GB  17.1GB  logical   ext3
 7      55.9GB  73.1GB  17.2GB  logical   ext3
 8      73.1GB  91.0GB  17.9GB  logical   ext3
 9      91.0GB  112GB   21.5GB  logical   ext3
10      112GB   132GB   19.5GB  logical   ext3
11      132GB   146GB   13.6GB  logical   ext3

Comment 28 Harald Hoyer 2009-09-15 14:25:48 UTC
For the advanced user, here is a scratch version to test:

# rpm -e '*dracut*' --nodeps
# rpm -ivh 'http://koji.fedoraproject.org/koji/getfile?taskID=1680533&name=dracut-001-10.git4d924752.fc12.noarch.rpm'

Comment 29 Winfrid Tschiedel 2009-09-15 14:47:33 UTC
Hello Harald,

I am a little bit confused - 
in the meantime I did an automatic update of my rawhide installation -
my new kernel is vmlinuz-2.6.31-2.fc12.x86_64, 
initramfs-2.6.31-2.fc12.x86_64.img + config-2.6.31-2.fc12.x86_64

And everything worked fine without updating of dracut.

[root@rx220a ~]# cd /boot 
[root@rx220a boot]# dracut -f initramfs-2.6.31-2.fc12.x86_64.img 2.6.31-2.fc12.x86_64
W: Possible missing firmware ql8100_fw.bin for module qla2xxx.ko
W: Possible missing firmware aic94xx-seq.fw for module aic94xx.ko

63290 blocks

[root@rx220a boot]# lsinitrd initramfs-2.6.31-2.fc12.x86_64.img  | grep kpartx
init


The system just came up with the new generated initrd .

Thank you,

Winfrid

Comment 30 Harald Hoyer 2009-09-15 14:55:37 UTC
if all is fine, then please close this bug

Comment 31 Winfrid Tschiedel 2009-09-16 05:58:26 UTC
Hopefully this big doesn't pop up again.

Winfrid

Comment 32 Winfrid Tschiedel 2009-09-16 07:41:04 UTC
Just a remark, doing automatic updates also 
rpm -ivh
'http://koji.fedoraproject.org/koji/getfile?taskID=1680533&name=dracut-kernel-001-10.git4d924752.fc12.noarch.rpm'  
is required

Comment 33 Harald Hoyer 2009-09-16 08:10:24 UTC
you can remove dracut-kernel, it's not really needed.


Note You need to log in before you can comment on or make changes to this bug.