Bug 522234 - xsane crashes at startup with gtk error
Summary: xsane crashes at startup with gtk error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xsane
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 20:22 UTC by john bray
Modified: 2009-12-18 09:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-18 09:42:49 UTC


Attachments (Terms of Use)

Description john bray 2009-09-09 20:22:49 UTC
Description of problem:
start xsane.  it never comes up.  run from a terminal and see the following:
[jmb@cheetah Desktop]$ xsane

(xsane:4753): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
[jmb@cheetah Desktop]$ 

this is on a fully updated f10 system.

Version-Release number of selected component (if applicable):
xsane-0.997-1.fc10.x86_64

associated rpms are:
sane-frontends-1.0.14-8.fc10                  Thu Aug 20 14:09:46 2009
xsane-gimp-0.997-1.fc10                       Thu Aug 20 14:08:44 2009
xsane-0.997-1.fc10                            Thu Aug 20 14:08:11 2009
sane-backends-devel-1.0.20-4.fc10             Fri Jul 24 02:34:58 2009
sane-backends-libs-gphoto2-1.0.20-4.fc10      Fri Jul 24 02:34:48 2009
sane-backends-libs-1.0.20-4.fc10              Fri Jul 24 02:31:32 2009
sane-backends-1.0.20-4.fc10                   Fri Jul 24 02:30:02 2009
libsane-hpaio-2.8.12-6.fc10                   Wed Mar 18 17:31:53 2009


How reproducible:
appears to be 100%  tried it after a re-login and a reboot, just in case something was stale, and got same result.

Steps to Reproduce:
1.invoke xsane from command line
2.observe result from above.
3.
  
Actual results:
as above

Expected results:
heh. it runs.

Additional info:

Comment 1 john bray 2009-09-09 21:30:09 UTC
i neglected to mention in the original that it appears to get as far as putting up the scanning for devices window, but it never shows any devices.

i did further testing with scanimage.  -L option shows the scanner.  and scanimage appears to work perfectly with the following options:

scanimage -d epson2:libusb:001:004 --preview=no --mode gray --resolution 300 > image.tiff

i also tested xsane as root, and it fails identically.

so it appears that the basic sane scanning is working and the problem is apparently in xsane.

Comment 2 Bug Zapper 2009-11-18 12:14:24 UTC
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Bug Zapper 2009-12-18 09:42:49 UTC
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.