Bug 522247 - Pidgin-to-Pidgin calling doesnt work on fedora 11
Summary: Pidgin-to-Pidgin calling doesnt work on fedora 11
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 21:07 UTC by Aniket
Modified: 2010-06-28 14:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:34:02 UTC


Attachments (Terms of Use)
firewall settings on fedora (2.02 KB, text/plain)
2009-09-10 19:07 UTC, Aniket
no flags Details
firewall settings on Ubuntu (7.09 KB, text/plain)
2009-09-10 19:08 UTC, Aniket
no flags Details

Description Aniket 2009-09-09 21:07:53 UTC
Description of problem:
I have installed pidgin latest version with voice/video support for xmpp on 2 fedora 11 machine. When I try to call (both audio and audio/video) pidgin to  pidgin , the call never connects. The calling works fine with Gtalk/Gmail web client on the other side. 

Also there is a crash when I accept an incoming video call from Gmail web client. No such crash occurs if I start a video call to the web client. kk


Version-Release number of selected component (if applicable):
pidgin 2.6.2 
pidgin 2.6.1

How reproducible:
Always

Steps to Reproduce:
1.Instal pidgin with voice/video on 2 computers with fedora 11
2.initiate call from one computer
3.accept the call
  
Actual results:
Call doesnt connect

Expected results:
Call should connect

Additional info:
I have an upstream bugreport already since a long time. 
http://developer.pidgin.im/ticket/9963

Also, I tried calling between 2 pidgin instances running on Ubuntu 9.04, the calls connect fine. So I think it points to some bug in fedora packages.

Comment 1 Aniket 2009-09-09 21:16:38 UTC
Also from the debug logs I posted upstream, these are the relevant lines which I think point to the cause of the problem.

media: farsight-component-state-changed: component: 1 state: FAILED                                      
media: farsight-error: 108: Could not establish connection                                               
media: farsight-component-state-changed: component: 2 state: FAILED 

Also, I apologise for my noob bug reporting ways, but the upstream bug name says (crash on incoming video call from gmail", which is also a fedora specific issue. I have made further comments in that report about pidgin to pidgin calling too, kinda 2 issues rolled into one bug report.

Comment 2 Warren Togami 2009-09-09 21:19:05 UTC
Could you please install all relevant debuginfo and get a traceback of the crash?  We can't do anything without a report.

It would also be good to know what versions of the entire farsight2 stack Ubuntu is using vs. Fedora 11.

There might also be firewall differences between Fedora and Ubuntu.  Try it again after "service iptables stop".

Comment 3 Aniket 2009-09-10 19:06:55 UTC
Hi, 

I think its the firewall. When I disabled the firewall on fedora 11 , the calls started flowing through perfect. 
Then I checked the firewall status on Ubuntu 9.04 and it was OFF by default. So I turned on the firewall on Ubuntu using "sudo ufw enable" . 

Even now the calls worked between Ubuntu and Fedora. So to tst again, i turned on the Firewall on f11 and the calls stopped connecting. 

So to summarize, the status of firewall on Ubuntu did not matter and the status of the Firewall on Fedora decided if the calls connected or not. 

I am attaching the output of "iptables -L -n" from both fedora 11 and Ubuntu 9.04 here so we can investigate further.

Comment 4 Aniket 2009-09-10 19:07:38 UTC
Created attachment 360554 [details]
firewall settings on fedora

Comment 5 Aniket 2009-09-10 19:08:00 UTC
Created attachment 360555 [details]
firewall settings on Ubuntu

Comment 6 Bug Zapper 2010-04-28 10:15:57 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Bug Zapper 2010-06-28 14:34:02 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.