Bug 522248 - setroubleshoot: SELinux is preventing abrtd "read" access on /var/cache/abrt/kerneloops-1252443345-1/time.
Summary: setroubleshoot: SELinux is preventing abrtd "read" access on /var/cache/...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:418c406c5ab...
: 522257 522258 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 21:12 UTC by Chris Ward
Modified: 2009-09-09 22:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-09 22:08:46 UTC


Attachments (Terms of Use)

Description Chris Ward 2009-09-09 21:12:18 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing abrtd "read" access on
/var/cache/abrt/kerneloops-1252443345-1/time.

Detailed Description:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:abrt_var_cache_t:s0
Target Objects                /var/cache/abrt/kerneloops-1252443345-1/time [
                              file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 #1 SMP Tue
                              Aug 11 21:00:45 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 09 Sep 2009 08:41:29 PM CEST
Last Seen                     Wed 09 Sep 2009 08:41:29 PM CEST
Local ID                      cfa5a7f4-0de4-43c5-b2d5-0a87f8f693e8
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252521689.509:16): avc:  denied  { read } for  pid=1439 comm="abrtd" name="time" dev=dm-0 ino=22350 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252521689.509:16): arch=c000003e syscall=2 success=yes exit=8 a0=1f16168 a1=0 a2=1b6 a3=238 items=0 ppid=1 pid=1439 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:file read;

Comment 1 Daniel Walsh 2009-09-09 22:08:46 UTC
Fixed in selinux-policy-3.6.31-2.fc12.noarch

Comment 2 Daniel Walsh 2009-09-09 22:09:38 UTC
*** Bug 522257 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-09 22:09:54 UTC
*** Bug 522258 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.