Bug 522255 - Cannot install xz-debuginfo; conflicts with lzma-debuginfo
Summary: Cannot install xz-debuginfo; conflicts with lzma-debuginfo
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xz
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 21:38 UTC by Christopher Beland
Modified: 2013-07-02 23:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-02 08:58:48 UTC


Attachments (Terms of Use)

Description Christopher Beland 2009-09-09 21:38:48 UTC
"debuginfo-install xz" fails with:

  file /usr/lib/debug/usr/bin/lzcat.debug from install of xz-debuginfo-4.999.8-0.8.beta.20090817git.fc11.x86_64 conflicts with file from package lzma-debuginfo-4.32.7-2.fc11.x86_64
  file /usr/lib/debug/usr/bin/lzma.debug from install of xz-debuginfo-4.999.8-0.8.beta.20090817git.fc11.x86_64 conflicts with file from package lzma-debuginfo-4.32.7-2.fc11.x86_64
  file /usr/lib/debug/usr/bin/lzmadec.debug from install of xz-debuginfo-4.999.8-0.8.beta.20090817git.fc11.x86_64 conflicts with file from package lzma-debuginfo-4.32.7-2.fc11.x86_64
  file /usr/lib/debug/usr/bin/lzmainfo.debug from install of xz-debuginfo-4.999.8-0.8.beta.20090817git.fc11.x86_64 conflicts with file from package lzma-debuginfo-4.32.7-2.fc11.x86_64
  file /usr/lib/debug/usr/bin/unlzma.debug from install of xz-debuginfo-4.999.8-0.8.beta.20090817git.fc11.x86_64 conflicts with file from package lzma-debuginfo-4.32.7-2.fc11.x86_64

Comment 1 Jindrich Novy 2009-09-10 01:23:25 UTC
The debuginfo packages do indeed conflict. The problem is that there is no way how to explictly obsolete debuginfo packages because debuginfos are automatically generated and their dependencies are not checked. Or better to say the debuginfo packages have no dependencies on the package it should be used with and do not inherit any Obsoletes/Provides.

There is no general way to avoid the conflict except manually removing the lzma-debuginfo before installing xz-debuginfo IMO.

Comment 2 Christopher Beland 2009-09-22 17:26:30 UTC
Well, need to have both xz and lzma-libs installed as dependencies of basic packages:

man-1.6f-20.fc11.i586
 -> xz-lzma-compat-4.999.8-0.8.beta.20090817git.fc11.i586
    -> xz = 4.999.8-0.8.beta.20090817git.fc11

PackageKit-0.4.9-1.fc11.i586
 -> libarchive-2.6.2-1.fc11.i586
    -> liblzmadec.so.0 (lzma-libs)

I was trying to run "debuginfo-install `rpm -qa | grep -v debuginfo`" so I would be ready to give a good backtrace when something crashes, obviously without knowing in advance what will crash.  Not being able to install both debuginfo packages means either man or PackageKit crashes won't be debuggable.

If I only really need one of these debuginfo RPMs, then it seems that something in the build process should be changed so debuginfo-install does the right thing, no?  (If so, I'm happy to report that somewhere else, wherever that might be.)

Comment 3 Jindrich Novy 2009-10-02 08:58:48 UTC
Sorry, this cannot be addressed in Fedora 11 because we have both lzma and xz in the distribution. The intention is to remove the the old lzma completely from Fedora 12 and on so no such conflict should occur any more because the lzma dependencies are now rebuilt against xz-compat-lzma.

In the current state it is not resolvable in Fedora 11 without intrusive changes to F11 RPM.

Comment 4 Christopher Beland 2009-10-27 14:03:41 UTC
Confirmed that this is not an issue in Fedora 12 (Rawhide desktop-i386-20091024.19.iso).  Thanks for the diagnosis!


Note You need to log in before you can comment on or make changes to this bug.