Bug 522263 - setroubleshoot: SELinux is preventing freshclam "read" access on /var/lib/clamav/mirrors.dat.
Summary: setroubleshoot: SELinux is preventing freshclam "read" access on /var/li...
Keywords:
Status: CLOSED DUPLICATE of bug 522262
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0ef3a9caabd...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 22:11 UTC by Nicolas Mailhot
Modified: 2009-09-09 22:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-09 22:27:58 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2009-09-09 22:11:44 UTC
The following was filed automatically by setroubleshoot:

Résumé:

SELinux is preventing freshclam "read" access on /var/lib/clamav/mirrors.dat.

Description détaillée:

[freshclam has a permissive type (system_cronjob_t). This access was not
denied.]

SELinux denied access requested by freshclam. It is not expected that this
access is required by freshclam and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Autoriser l'accès:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informations complémentaires:

Contexte source               system_u:system_r:system_cronjob_t:s0-s0:c0.c1023
Contexte cible                system_u:object_r:clamd_var_lib_t:s0
Objets du contexte            /var/lib/clamav/mirrors.dat [ file ]
source                        freshclam
Chemin de la source           /usr/bin/freshclam
Port                          <Inconnu>
Hôte                         (removed)
Paquetages RPM source         clamav-update-0.95.2-5.fc12
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.6.30-6.fc12
Selinux activé               True
Type de politique             targeted
MLS activé                   True
Mode strict                   Enforcing
Nom du plugin                 catchall
Nom de l'hôte                (removed)
Plateforme                    Linux (removed) 2.6.31-0.219.rc9.git2.fc12.x86_64
                              #1 SMP Wed Sep 9 05:55:59 EDT 2009 x86_64 x86_64
Compteur d'alertes            2
Première alerte              jeu. 10 sept. 2009 00:01:55 CEST
Dernière alerte              jeu. 10 sept. 2009 00:01:55 CEST
ID local                      e02bbda9-2d58-46a0-b371-7288b5619290
Numéros des lignes           

Messages d'audit bruts        

node=(removed) type=AVC msg=audit(1252533715.219:285): avc:  denied  { read } for  pid=4661 comm="freshclam" name="mirrors.dat" dev=dm-3 ino=164825 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:clamd_var_lib_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1252533715.219:285): avc:  denied  { open } for  pid=4661 comm="freshclam" name="mirrors.dat" dev=dm-3 ino=164825 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:clamd_var_lib_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252533715.219:285): arch=c000003e syscall=2 success=yes exit=4 a0=41a6a0 a1=0 a2=1 a3=7fff909590f0 items=0 ppid=4612 pid=4661 auid=0 uid=492 gid=487 euid=492 suid=492 fsuid=492 egid=487 sgid=487 fsgid=487 tty=(none) ses=18 comm="freshclam" exe="/usr/bin/freshclam" subj=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= system_cronjob_t ==============
allow system_cronjob_t clamd_var_lib_t:file { read open };

Comment 1 Daniel Walsh 2009-09-09 22:27:58 UTC
One bug is plenty

*** This bug has been marked as a duplicate of bug 522262 ***


Note You need to log in before you can comment on or make changes to this bug.