Bug 522270 - Can't configure lcdproc to use the lis driver (lis.so)
Summary: Can't configure lcdproc to use the lis driver (lis.so)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lcdproc
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 22:55 UTC by Peter Bergeron
Modified: 2009-09-10 20:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 13:38:47 UTC


Attachments (Terms of Use)

Description Peter Bergeron 2009-09-09 22:55:11 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2

lcdproc-0.5.3-3.fc12.i686.rpm does not contain the lis driver, but driver is included in the 0.5.3 source (new in 0.5.3). Trying to configure LCDd to use the lis driver results in an error.

Reproducible: Always

Steps to Reproduce:
1. Install lcdproc-0.5.3-3.
2. Configure LCDd.conf to use the lis driver.
3. Attempt to start LCDd.
Actual Results:  
[root@mythtv lcdproc]# service LCDd start
Starting LCDd service: Could not open driver module /usr/lib/lcdproc/lis.so: /usr/lib/lcdproc/lis.so: cannot open shared object file: No such file or directory
Driver [lis] binding failed
Could not load driver lis
There is no output driver
Critical error while initializing, abort.
                                                           [FAILED]


Expected Results:  
LCDd service starts without error when configured to use lis.

Looking at spec file, it looks like the spec attempts to build all drivers (--enable-drivers=all). I see there is no BuildRequires for libftdi-devel, and the lcdproc user documentation included with 0.5.3 notes that the lis driver requires libftdi, version 0.8 or higher (version 0.16 is currently in Rawhide). 

Perhaps the missing BR is the problem? I don't have a build environment to test this out on myself. Saw the lcdproc release notes about the new lis driver so I'm hoping this gets my nMedia PRO-LCD working some day...

Comment 1 Jarod Wilson 2009-09-10 13:24:34 UTC
Yep, adding BuildRequires: libftdi-devel looks like it should fix this. Just did a local build that includes lis.so, anyway. Committing, tagging and building for rawhide now.

Comment 2 Jarod Wilson 2009-09-10 13:38:47 UTC
Yep, its there in the build that just finished in koji too:

http://koji.fedoraproject.org/koji/buildinfo?buildID=131398

Give it a go when you have a chance. I'm going to assume we're all set though, and close this bug...

Comment 3 Peter Bergeron 2009-09-10 20:00:04 UTC
Confirmed that the lis driver is now in lcdproc-0.5.3-4.fc12.i686.rpm. Even better, it works with my nMedia PRO-LCD!

Thanks!


Note You need to log in before you can comment on or make changes to this bug.