Bug 522274 - Some DomUs may not restart with 'xm reboot -a'
Summary: Some DomUs may not restart with 'xm reboot -a'
Keywords:
Status: CLOSED DUPLICATE of bug 518104
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 23:13 UTC by Bryan Mason
Modified: 2010-04-08 16:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 07:30:30 UTC


Attachments (Terms of Use)

Description Bryan Mason 2009-09-09 23:13:40 UTC
Description of problem:

   Running 'xm reboot -a' may result in some DomUs not being
   rebooted, and others being in an inaccessible state.

Version-Release number of selected component (if applicable):

    xen-3.0.3-94.el5

How reproducible:

    Most of the time.

Steps to Reproduce:

    1. Start several pv guests.
    2. run 'xm reboot -a'
  
Actual results:

    Chaos.  After the attempted reboot of all guest domains, some (or
    all) of the domains will not be restarted.  Running 'xm list'
    shows something like:

        # xm list
        Name                              ID Mem(MiB) VCPUs State   Time(s)
        Domain-0                           0      444     1 r-----    119.9
        Zombie-rhel52-test                 9      256     1 ------      5.0
        Zombie-rhel52-test                10      256     1 ----c-      0.2

Expected results:

    Joy and harmony.  All guests should restart successfully.

Additional info:

    It is reported that this worked fine in xen-3.0.3-64.el5_2.3, but
    is a problem with xen-3.0.3-64.el5_2.9 as well as the latest
    version in RHEL 5.4 (xen-xen-3.0.3-94.el5).  I have verified the
    problem with xen-3.0.3-80.el5.

Comment 2 Jiri Denemark 2009-09-10 08:05:19 UTC
I suspect this could be caused by bug 518104, I'll prepare testing packages to check if my suspicion is right...

Comment 3 Jiri Denemark 2009-09-10 12:24:02 UTC
Could you please try the packages at http://people.redhat.com/jdenemar/xen/bz522274/ to see if that fixes your issue?

Thanks.

Comment 5 Jiri Denemark 2009-09-16 07:30:30 UTC
Great, thank you very much for the testing which confirms that this bug is solved by patches for bug 513604 and bug 518104. I'm going to close this bug as a duplicate of the latter (although both of them are most likely needed). Both BZs are nominated for Z-stream, so once they are approved, built and tested by QA, you should be able to get them as an update.

*** This bug has been marked as a duplicate of bug 518104 ***

Comment 6 Paolo Bonzini 2010-04-08 15:45:47 UTC
This bug was closed during 5.5 development and it's being removed from the internal tracking bugs (which are now for 5.6).


Note You need to log in before you can comment on or make changes to this bug.